Run of fresh-releases for ruby-hipchat

Try this locally (using silver-platter):

debian-svp new-upstream ruby-hipchat 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
Processing: ruby-hipchat
Total 0 (delta 0), reused 0 (delta 0)
/usr/lib/python3/dist-packages/debian/copyright.py:654: UserWarning: Fixing Format URL
  warnings.warn('Fixing Format URL')
Using upstream branch https://github.com/hipchat/hipchat-rb (guessed)
Total 2053 (delta 0), reused 0 (delta 0), pack-reused 2053
uscan warn: redirecting DEPRECATED pkg-ruby-extras.alioth.debian.org/cgi-bin/gemwatch to gemwatch.debian.net
redirecting DEPRECATED pkg-ruby-extras.alioth.debian.org/cgi-bin/gemwatch to gemwatch.debian.net
Using version string 1.6.0.
No upstream upstream-revision format specified, trying tag:1.6.0
No upstream upstream-revision format specified, trying tag:ruby-hipchat-1.6.0
No upstream upstream-revision format specified, trying tag:v1.6.0
Using uscan to look for the upstream tarball.
uscan warn: redirecting DEPRECATED pkg-ruby-extras.alioth.debian.org/cgi-bin/gemwatch to gemwatch.debian.net
redirecting DEPRECATED pkg-ruby-extras.alioth.debian.org/cgi-bin/gemwatch to gemwatch.debian.net
Total 1995 (delta 0), reused 0 (delta 0), pack-reused 1995
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.5.1 points at non-present sha e70a5fdf94238f8a40a6423b3c763c1040f06cd1
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.3.0 points at non-present sha eb1f83852d02a735cfa20b192875f56bcd463f36
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.0.0 points at non-present sha 551736ba513d344d5bacb0e4d8926d8af499d84d
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.5.0 points at non-present sha 786c82107a3a1f36f18a15933b55ba58967b83de
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.10.0 points at non-present sha deb384df1240176b56fd2353f3ef5235199e1ba8
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.1.0 points at non-present sha ee5bfaa84703b8796b68b7b50d93c0935e3fe15d
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.2.0 points at non-present sha a4012074e5c620499acf28ff9c416e012fdb6e6e
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.11.0 points at non-present sha 9a22eb382d7a7821fc742ad44ad052868c0d5074
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.10.1 points at non-present sha b21a3aa48548f6bbfc20960ac4aa56f9e4c78b68
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.13.0 points at non-present sha c917c291c806d809cc7632e202705ed819c6beea
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.12.0 points at non-present sha 437f1395eb19a466ed6d0e784a22114ead4e4478
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.0.1 points at non-present sha 666a9449334d6b1ea1499912de1faf81408042ab
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.14.0 points at non-present sha 25bf3695ed53e4300117fbab11e4f5ed1b62a9d4
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.4.0 points at non-present sha babdee0effe41248efe8232edffd3994cd544a5f
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.5.4 points at non-present sha 04c21e435872889aaecef99ff49be9f8de99ba12
  UserWarning)
Not storing pristine-tar metadata, since there is no pristine-tar branch.
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.5.1 points at non-present sha e70a5fdf94238f8a40a6423b3c763c1040f06cd1
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.3.0 points at non-present sha eb1f83852d02a735cfa20b192875f56bcd463f36
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.0.0 points at non-present sha 551736ba513d344d5bacb0e4d8926d8af499d84d
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.5.0 points at non-present sha 786c82107a3a1f36f18a15933b55ba58967b83de
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.10.0 points at non-present sha deb384df1240176b56fd2353f3ef5235199e1ba8
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.1.0 points at non-present sha ee5bfaa84703b8796b68b7b50d93c0935e3fe15d
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.2.0 points at non-present sha a4012074e5c620499acf28ff9c416e012fdb6e6e
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.11.0 points at non-present sha 9a22eb382d7a7821fc742ad44ad052868c0d5074
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.10.1 points at non-present sha b21a3aa48548f6bbfc20960ac4aa56f9e4c78b68
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.13.0 points at non-present sha c917c291c806d809cc7632e202705ed819c6beea
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.12.0 points at non-present sha 437f1395eb19a466ed6d0e784a22114ead4e4478
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.0.1 points at non-present sha 666a9449334d6b1ea1499912de1faf81408042ab
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v0.14.0 points at non-present sha 25bf3695ed53e4300117fbab11e4f5ed1b62a9d4
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.4.0 points at non-present sha babdee0effe41248efe8232edffd3994cd544a5f
  UserWarning)
/usr/lib/python3/dist-packages/dulwich/repo.py:415: UserWarning: ref refs/tags/v1.5.4 points at non-present sha 04c21e435872889aaecef99ff49be9f8de99ba12
  UserWarning)
v1.5.1 does not point to a valid object
v1.3.0 does not point to a valid object
v1.0.0 does not point to a valid object
v1.5.0 does not point to a valid object
v0.10.0 does not point to a valid object
v1.1.0 does not point to a valid object
v1.2.0 does not point to a valid object
v0.11.0 does not point to a valid object
v0.10.1 does not point to a valid object
v0.13.0 does not point to a valid object
v0.12.0 does not point to a valid object
v1.0.1 does not point to a valid object
v0.14.0 does not point to a valid object
v1.4.0 does not point to a valid object
v1.5.4 does not point to a valid object
All changes applied successfully.
v1.5.1 does not point to a valid object
v1.3.0 does not point to a valid object
v1.0.0 does not point to a valid object
v1.5.0 does not point to a valid object
v0.10.0 does not point to a valid object
v1.1.0 does not point to a valid object
v1.2.0 does not point to a valid object
v0.11.0 does not point to a valid object
v0.10.1 does not point to a valid object
v0.13.0 does not point to a valid object
v0.12.0 does not point to a valid object
v1.0.1 does not point to a valid object
v0.14.0 does not point to a valid object
v1.4.0 does not point to a valid object
v1.5.4 does not point to a valid object
Committing to: /home/janitor/tmp/tmpvl50j4er/ruby-hipchat/
modified .ruby-version
modified .travis.yml
modified README.textile
modified debian/changelog
modified hipchat.gemspec
modified lib/hipchat/api_version.rb
modified lib/hipchat/capistrano/tasks/hipchat.rake
modified lib/hipchat/client.rb
modified lib/hipchat/errors.rb
modified lib/hipchat/railtie.rb
modified lib/hipchat/room.rb
modified lib/hipchat/user.rb
modified lib/hipchat/version.rb
deleted metadata.yml
modified spec/hipchat_api_v1_spec.rb
modified spec/hipchat_api_v2_spec.rb
added spec/hipchat_error_handler_spec.rb
modified spec/hipchat_spec.rb
modified spec/spec_helper.rb
modified spec/support/shared_contexts_for_hipchat.rb
added tests.py
Committed revision 20.
Worker failed: An error occurred refreshing quilt patch fix-tests-support-rspec3: 

Applying patch debian/patches/fix-tests-support-rspec3
patching file spec/hipchat_api_v2_spec.rb
Hunk #1 FAILED at 203.
Hunk #2 FAILED at 211.
Hunk #3 FAILED at 219.
Hunk #4 FAILED at 231.
Hunk #5 FAILED at 332.
Hunk #6 FAILED at 353.
Hunk #7 FAILED at 361.
Hunk #8 FAILED at 369.
8 out of 8 hunks FAILED -- rejects in file spec/hipchat_api_v2_spec.rb
patching file spec/spec_helper.rb
Hunk #1 FAILED at 2.
1 out of 1 hunk FAILED -- rejects in file spec/spec_helper.rb
Patch debian/patches/fix-tests-support-rspec3 does not apply (enforce with -f)

Elapsed time: 0:01:14.743743

Full worker log