Lintian Fixes - acpica-unix

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/acpica-unix lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2020-04-01 02:28:35 +0000
+++ b/debian/changelog	2020-04-28 14:36:46 +0000
@@ -1,13 +1,25 @@
+acpica-unix (20200326-2) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Use secure URI in Homepage field.
+  * Bump debhelper from old 10 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit.
+  * Rely on pre-initialized dpkg-architecture variables.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Tue, 28 Apr 2020 14:32:50 +0000
+
 acpica-unix (20200326-1) unstable; urgency=medium
 
-  * Upgrade to 20200326 upstream 
+  * Upgrade to 20200326 upstream
   * Refresh patches as needed
 
  -- Al Stone <ahs3@debian.org>  Tue, 31 Mar 2020 20:15:17 -0600
 
 acpica-unix (20200214-2) unstable; urgency=medium
 
-  * Add patch for FACP defaults 
+  * Add patch for FACP defaults
   * Add patches to accommodate future use of -fno-common by default
   * Add patches to work better with GCC being stricter about the use
     of strings and expecting null terminators
@@ -20,7 +32,7 @@
 
 acpica-unix (20200214-1) unstable; urgency=medium
 
-  * Upgrade to 20200214 upstream 
+  * Upgrade to 20200214 upstream
   * Refresh patches as needed
 
  -- Al Stone <ahs3@debian.org>  Tue, 18 Feb 2020 20:34:25 -0700
@@ -181,7 +193,7 @@
   * Refresh patches as needed
   * CVE-2017-13693: operand cache leak in dsutils.c (patch from github
     applied)
-  * CVE-2017-13694: acpi parse and parseext cache leak in psobjects.c 
+  * CVE-2017-13694: acpi parse and parseext cache leak in psobjects.c
     (patch from github applied)
   * CVE-2017-13695: operand cache leak in nseval.c (patch from github
     applied)
@@ -243,28 +255,28 @@
 
 acpica-unix (20170303-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- Al Stone <ahs3@debian.org>  Tue, 04 Apr 2017 12:06:55 -0600
 
 acpica-unix (20160930-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- Al Stone <ahs3@debian.org>  Tue, 04 Oct 2016 16:41:11 -0600
 
 acpica-unix (20160831-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- Al Stone <ahs3@debian.org>  Thu, 01 Sep 2016 12:28:36 -0600
 
 acpica-unix (20160729-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- Al Stone <ahs3@debian.org>  Tue, 02 Aug 2016 17:08:49 -0600
@@ -278,7 +290,7 @@
 
 acpica-unix (20160527-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
   * Update Standards-Version to most recent
 
@@ -286,7 +298,7 @@
 
 acpica-unix (20160422-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
   * Update Standards-Version to most recent
 
@@ -294,14 +306,14 @@
 
 acpica-unix (20160318-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- Al Stone <ahs3@debian.org>  Sat, 19 Mar 2016 15:44:00 -0600
 
 acpica-unix (20160212-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
   * Fix silly typo in Vcs-* entries in debian/control
 
@@ -309,7 +321,7 @@
 
 acpica-unix (20160108-2) unstable; urgency=medium
 
-  * Closes: #757791 -- use proper Vcs-* lines in the control file. 
+  * Closes: #757791 -- use proper Vcs-* lines in the control file.
   * Closes: #731761 -- add changelog info on turbostat: unfortunately,
     during the transition to using only the ACPICA upstream source tree,
     I forgot to mention that turbostat was not part of that source but
@@ -339,21 +351,21 @@
 
 acpica-unix (20160108-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- ahs3 <ahs3@debian.org>  Mon, 11 Jan 2016 17:45:19 -0700
 
 acpica-unix (20151218-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- ahs3 <ahs3@debian.org>  Thu, 07 Jan 2016 13:00:33 -0700
 
 acpica-unix (20151124-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
   * Add back in a patch to fix a file name that upstream inadvertently left
     in camel case.
@@ -362,7 +374,7 @@
 
 acpica-unix (20150930-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- ahs3 <ahs3@debian.org>  Thu, 15 Oct 2015 12:30:33 -0600
@@ -383,7 +395,7 @@
 
 acpica-unix (20150717-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
   * Add new patch to correct AAPITS makefile after source file name changes
 
@@ -391,7 +403,7 @@
 
 acpica-unix (20150619-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.  Patches for NFIT UUIDs, ARM GICs,
     and /dev/mem removed as no longer needed.
 
@@ -406,9 +418,9 @@
 
 acpica-unix (20150515-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
-  * Add correction patch for NFIT UUIDs (from mailing list) 
+  * Add correction patch for NFIT UUIDs (from mailing list)
   * Update Standards-Version to 3.9.6
   * Add patch from Linaro to remove reliance on /dev/mem for some tables.
   * Add patch to correct ARM GICs in MADT (from mailing list)
@@ -418,28 +430,28 @@
 
 acpica-unix (20150410-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- ahs3 <ahs3@debian.org>  Mon, 13 Apr 2015 20:24:58 -0600
 
 acpica-unix (20150408-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- ahs3 <ahs3@debian.org>  Wed, 08 Apr 2015 19:43:17 -0600
 
 acpica-unix (20150204-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Refresh patches as needed.
 
  -- ahs3 <ahs3@debian.org>  Mon, 02 Mar 2015 16:41:10 -0700
 
 acpica-unix (20141107-1) unstable; urgency=medium
 
-  * Upgrade to latest upsteam 
+  * Upgrade to latest upsteam
   * Refresh patches as needed.
 
  -- ahs3 <ahs3@debian.org>  Mon, 17 Nov 2014 18:06:06 -0700
@@ -470,13 +482,13 @@
 
 acpica-unix (20140424-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
 
  -- Al Stone <ahs3@debian.org>  Wed, 07 May 2014 14:30:05 -0600
 
 acpica-unix (20140325-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Closes: #743011 -- don't rely on uname to determine word size; just
     used the patch supplied in the BTS
 
@@ -493,7 +505,7 @@
 
 acpica-unix (20140114-1) unstable; urgency=medium
 
-  * Upgrade to latest upstream. 
+  * Upgrade to latest upstream.
   * Remove temporary patch for forgotten Makefile.
   * Add patch to fix aapits test suite Makefile.
 
@@ -525,7 +537,7 @@
 
 acpica-unix (20131115-1) unstable; urgency=low
 
-  * Update to latest upstream. 
+  * Update to latest upstream.
 
  -- Al Stone <ahs3@debian.org>  Mon, 25 Nov 2013 15:31:42 -0700
 
@@ -537,25 +549,25 @@
 
 acpica-unix (20130823-2) unstable; urgency=low
 
-  * Fix the run-misc-tests.sh script to enable running on s390x. 
+  * Fix the run-misc-tests.sh script to enable running on s390x.
 
  -- Al Stone <ahs3@debian.org>  Tue, 10 Sep 2013 20:41:19 -0600
 
 acpica-unix (20130823-1) unstable; urgency=low
 
-  * Update to latest upstream. 
+  * Update to latest upstream.
 
  -- Al Stone <ahs3@debian.org>  Mon, 26 Aug 2013 13:36:15 -0600
 
 acpica-unix (20130725-1) unstable; urgency=low
 
-  * Update to latest upstream. 
+  * Update to latest upstream.
 
  -- Al Stone <ahs3@debian.org>  Sun, 18 Aug 2013 15:02:45 -0600
 
 acpica-unix (20130626-1) unstable; urgency=low
 
-  * Update to latest upstream. 
+  * Update to latest upstream.
   * Closes: bug#704822 -- properly clean up alternatives after purge;
     all the suggestions made in the bug have been applied
   * Closes: bug#714426 -- acpidump has been implemented for Linux
@@ -604,7 +616,7 @@
 acpica-unix (20130214-0.2) unstable; urgency=low
 
   * Non-maintainer upload.
-  * New upstream (since the last attempt at NMU). 
+  * New upstream (since the last attempt at NMU).
   * Clarify the licensing: this is being released under GPLv2 as allowed
     under the original dual-licensing from Intel.
   * Corrected integer to pointer conversion resulting from an incorrect
@@ -710,67 +722,67 @@
 
   * Fix FTBFS on Debian/KFreeBsd. (Closes: #401617)
   * high urgency due to the RC bug being closed in -2.
- 
+
  -- Mattia Dongili <malattia@debian.org>  Mon, 04 Dec 2006 23:40:28 +0100
 
 acpica-unix (20060912-2) unstable; urgency=high
 
   * Fix segfault compiling qemu's DSDT on powerpc (Closes: #401153)
   * high urgency due to the RC bug being closed.
- 
+
  -- Mattia Dongili <malattia@debian.org>  Mon, 04 Dec 2006 19:25:28 +0100
 
 acpica-unix (20060912-1) unstable; urgency=low
 
   * New upstream release.
   * build-arch set to any as requested. (Closes: #389512)
- 
+
  -- Mattia Dongili <malattia@debian.org>  Mon, 02 Oct 2006 19:00:06 +0200
 
 acpica-unix (20060707-1) unstable; urgency=low
 
   * New upstream release.
- 
+
  -- Mattia Dongili <malattia@debian.org>  Tue, 22 Aug 2006 19:29:39 +0200
- 
+
 acpica-unix (20060608-1) unstable; urgency=low
 
   * New upstream release.
- 
+
  -- Mattia Dongili <malattia@debian.org>  Tue, 27 Jun 2006 21:23:46 +0200
- 
+
 acpica-unix (20060421-1) unstable; urgency=low
 
   * New upstream release.
   * Upstream included the GNU/kFreeBSD patch
   * Added kfreebsd-amd64 architecture (Closes: #361610)
- 
+
  -- Mattia Dongili <malattia@debian.org>  Sat, 29 Apr 2006 09:16:49 +0200
- 
+
 acpica-unix (20060317-1) unstable; urgency=low
 
   * New upstream release.
- 
+
  -- Mattia Dongili <malattia@debian.org>  Tue, 28 Mar 2006 19:08:16 +0200
- 
+
 acpica-unix (20060217-1) unstable; urgency=low
 
   * New upstream release.
- 
+
  -- Mattia Dongili <malattia@debian.org>  Mon, 06 Mar 2006 19:53:22 +0100
- 
+
 acpica-unix (20060113-1) unstable; urgency=low
 
   * New upstream release.
- 
+
  -- Mattia Dongili <malattia@debian.org>  Sun, 22 Jan 2006 10:54:55 +0100
- 
+
 acpica-unix (20051216-1) unstable; urgency=low
 
   * New upstream release.
- 
+
  -- Mattia Dongili <malattia@debian.org>  Sun, 08 Jan 2006 16:25:12 +0100
- 
+
 acpica-unix (20051117-1) unstable; urgency=low
 
   * New upstream release.
@@ -784,4 +796,3 @@
   * Initial release Closes: #333603
 
  -- Mattia Dongili <malattia@debian.org>  Fri, 14 Oct 2005 19:16:28 +0200
-

=== removed file 'debian/compat'
--- a/debian/compat	2018-05-15 15:52:14 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-10

=== modified file 'debian/control'
--- a/debian/control	2019-10-24 02:17:30 +0000
+++ b/debian/control	2020-04-28 14:36:46 +0000
@@ -2,11 +2,11 @@
 Section: devel
 Priority: optional
 Maintainer: Al Stone <ahs3@debian.org>
-Build-Depends: debhelper (>= 10~), flex, bison
-Standards-Version: 4.4.1
+Build-Depends: debhelper-compat (= 12), flex, bison
+Standards-Version: 4.5.0
 Vcs-Git: https://github.com/ahs3/acpica-tools.git
 Vcs-Browser: https://github.com/ahs3/acpica-tools
-Homepage: http://www.acpica.org
+Homepage: https://www.acpica.org
 
 Package: acpica-tools
 Architecture: any
@@ -37,4 +37,3 @@
        for specific environments
     -- acpixtract: extract binary ACPI tables from acpidump output (see
        also the pmtools package)
-

=== modified file 'debian/rules'
--- a/debian/rules	2020-04-01 02:28:35 +0000
+++ b/debian/rules	2020-04-28 14:36:11 +0000
@@ -17,8 +17,7 @@
 
 VERSION = 20200326
 
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+include /usr/share/dpkg/architecture.mk
 
 ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
 	CC = $(DEB_HOST_GNU_TYPE)-gcc

=== added directory 'debian/upstream'
=== added file 'debian/upstream/metadata'
--- a/debian/upstream/metadata	1970-01-01 00:00:00 +0000
+++ b/debian/upstream/metadata	2020-04-28 14:35:34 +0000
@@ -0,0 +1,2 @@
+Bug-Database: https://github.com/acpica/acpica/issues
+Bug-Submit: https://github.com/acpica/acpica/issues/new

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/lib/debug/.dwz/x86_64-linux-gnu/acpica-tools.debug

Control files of package acpica-tools: lines which differ (wdiff format)

  • Homepage: http://www.acpica.org https://www.acpica.org

No differences were encountered between the control files of package acpica-tools-dbgsym

Run locally

Try this locally (using the lintian-brush package):

debcheckout acpica-unix
cd acpica-unix
lintian-brush

More details

Full run details