Lintian Fixes - agenda.app

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/agenda.app lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2020-02-05 10:20:49 +0000
+++ b/debian/changelog	2020-04-11 00:41:52 +0000
@@ -1,3 +1,11 @@
+agenda.app (0.44-3) UNRELEASED; urgency=medium
+
+  * Bump debhelper from old 11 to 12.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+    Repository-Browse.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 11 Apr 2020 00:41:03 +0000
+
 agenda.app (0.44-2) unstable; urgency=medium
 
   * Team upload.

=== modified file 'debian/compat'
--- a/debian/compat	2020-02-05 10:20:49 +0000
+++ b/debian/compat	2020-04-11 00:41:16 +0000
@@ -1,1 +1,1 @@
-11
+12

=== modified file 'debian/control'
--- a/debian/control	2020-02-05 10:20:49 +0000
+++ b/debian/control	2020-04-11 00:41:16 +0000
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian GNUstep maintainers <pkg-gnustep-maintainers@lists.alioth.debian.org>
 Uploaders: Yavor Doganov <yavor@gnu.org>
-Build-Depends: debhelper (>= 11),
+Build-Depends: debhelper (>= 12~),
 	       gnustep-make (>= 2.7.0-3),
 	       libgnustep-gui-dev,
 	       libaddresses-dev,

=== added directory 'debian/upstream'
=== added file 'debian/upstream/metadata'
--- a/debian/upstream/metadata	1970-01-01 00:00:00 +0000
+++ b/debian/upstream/metadata	2020-04-11 00:41:52 +0000
@@ -0,0 +1,4 @@
+Bug-Database: https://github.com/poroussel/simpleagenda/issues
+Bug-Submit: https://github.com/poroussel/simpleagenda/issues/new
+Repository: https://github.com/poroussel/simpleagenda.git
+Repository-Browse: https://github.com/poroussel/simpleagenda

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package agenda.app

No differences were encountered between the control files of package agenda.app-dbgsym

Run locally

Try this locally (using the lintian-brush package):

debcheckout agenda.app
cd agenda.app
lintian-brush --exclude=uses-debhelper-compat-file

More details

Full run details