Lintian Fixes - dune-pdelab

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/dune-pdelab lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2019-10-23 17:13:36 +0000
+++ b/debian/changelog	2019-11-18 04:22:02 +0000
@@ -1,3 +1,11 @@
+dune-pdelab (2.6~20180302-3) UNRELEASED; urgency=medium
+
+  * Bump debhelper from old 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Drop unnecessary dh arguments: --parallel
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 18 Nov 2019 04:21:13 +0000
+
 dune-pdelab (2.6~20180302-2) unstable; urgency=medium
 
   * d/control: Build-Depend on libalberta-dev instead of libalberta2-dev.

=== removed file 'debian/compat'
--- a/debian/compat	2012-03-01 23:26:39 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-9

=== modified file 'debian/control'
--- a/debian/control	2019-10-23 17:10:10 +0000
+++ b/debian/control	2019-11-18 04:21:41 +0000
@@ -7,7 +7,7 @@
 Vcs-Browser: https://salsa.debian.org/science-team/dune-pdelab
 Vcs-Git: https://salsa.debian.org/science-team/dune-pdelab.git
 Homepage: https://www.dune-project.org/modules/dune-pdelab/
-Build-Depends: debhelper (>= 9),
+Build-Depends: debhelper-compat (= 12),
  cmake, gfortran, mpi-default-bin, mpi-default-dev, pkg-config, python3,
  libdune-common-dev (>= 2.6.0),
  libdune-functions-dev (>= 2.6~),

=== modified file 'debian/rules'
--- a/debian/rules	2016-12-06 00:50:37 +0000
+++ b/debian/rules	2019-11-18 04:22:02 +0000
@@ -3,4 +3,4 @@
 include /usr/share/dune/dune-debian.mk
 
 %:
-	dh $@ --parallel --builddirectory=build
+	dh $@ --builddirectory=build

Run locally

Try this locally (using the lintian-brush package):

debcheckout dune-pdelab
cd dune-pdelab
lintian-brush

More details

Full run details