Lintian Fixes - emacs-helm-ag

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/emacs-helm-ag lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2020-05-17 23:38:43 +0000
+++ b/debian/changelog	2020-06-04 15:26:28 +0000
@@ -1,3 +1,12 @@
+emacs-helm-ag (0.59-2) UNRELEASED; urgency=low
+
+  * Bump debhelper from old 10 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+    Repository-Browse.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 04 Jun 2020 15:24:50 -0000
+
 emacs-helm-ag (0.59-1) unstable; urgency=medium
 
   [ David Krauser ]

=== removed file 'debian/compat'
--- a/debian/compat	2017-10-25 17:02:59 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-10

=== modified file 'debian/control'
--- a/debian/control	2019-10-24 20:26:27 +0000
+++ b/debian/control	2020-06-04 15:25:43 +0000
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian Emacsen Team <debian-emacsen@lists.debian.org>
 Uploaders: Sean Whitton <spwhitton@spwhitton.name>
-Build-Depends: debhelper (>= 10),
+Build-Depends: debhelper-compat (= 12),
  dh-elpa,
  elpa-helm,
  silversearcher-ag,

=== added directory 'debian/upstream'
=== added file 'debian/upstream/metadata'
--- a/debian/upstream/metadata	1970-01-01 00:00:00 +0000
+++ b/debian/upstream/metadata	2020-06-04 15:26:28 +0000
@@ -0,0 +1,5 @@
+---
+Bug-Database: https://github.com/syohex/emacs-helm-ag/issues
+Bug-Submit: https://github.com/syohex/emacs-helm-ag/issues/new
+Repository: https://github.com/syohex/emacs-helm-ag.git
+Repository-Browse: https://github.com/syohex/emacs-helm-ag

Run locally

Try this locally (using the lintian-brush package):

debcheckout emacs-helm-ag
cd emacs-helm-ag
lintian-brush

More details

Full run details