Lintian Fixes - fbonds

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/fbonds lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2020-05-17 23:45:13 +0000
+++ b/debian/changelog	2020-06-11 20:34:23 +0000
@@ -1,3 +1,11 @@
+fbonds (3042.78-5) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from deprecated 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 11 Jun 2020 20:32:47 -0000
+
 fbonds (3042.78-4) unstable; urgency=medium
 
   * Rebuilt for r-4.0 transition
@@ -16,10 +24,10 @@
 fbonds (3042.78-2) unstable; urgency=medium
 
   * Rebuilding for R 3.5.0 transition
-  
+
   * debian/control: Set Build-Depends: to current R version
   * debian/control: Set Build-Depends: to 'debhelper (>= 10)'
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
   * debian/control: Add Vcs-Browser: and Vcs-Git:
   * debian/compat: Increase level to 9
   * debian/control: Switch from cdbs to dh-r
@@ -31,8 +39,8 @@
 
   * New upstream release
 
-  * debian/control: Set Standards-Version: to current version 
-  * debian/control: Set Build-Depends: to current R version 
+  * debian/control: Set Standards-Version: to current version
+  * debian/control: Set Build-Depends: to current R version
   * debianb/control: Add Depends: on ${misc:Depends}
   * debian/compat: Set level to 9
 
@@ -41,9 +49,9 @@
 fbonds (3010.77-2) unstable; urgency=medium
 
   * debian/compat: Created			(Closes: #830470)
- 
+
   * debian/control: Set Build-Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Fri, 08 Jul 2016 07:11:46 -0500
 
@@ -52,14 +60,14 @@
   * New upstream release
 
   * debian/control: Set (Build-)Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Tue, 17 Dec 2013 19:10:34 -0600
 
 fbonds (2160.76-2) unstable; urgency=low
 
-  * debian/control: Set Build-Depends: to current R version 
-  
+  * debian/control: Set Build-Depends: to current R version
+
   * (Re-)building with R 3.0.0 (beta)
 
  -- Dirk Eddelbuettel <edd@debian.org>  Tue, 02 Apr 2013 07:03:17 -0500
@@ -70,7 +78,7 @@
 
   * debian/control: Set Build-Depends: to current R version
   * debian/control: Change Depends to ${R:Depends}
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Mon, 10 Dec 2012 15:26:56 -0600
 
@@ -79,7 +87,7 @@
   * Rebuilt for R 2.14.0 so that a default NAMESPACE file is created
 
   * debian/control: Set (Build-)Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Sat, 22 Oct 2011 17:26:35 -0500
 
@@ -96,7 +104,7 @@
   * New upstream release
 
   * debian/control: Set (Build-)Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Wed, 30 Sep 2009 20:39:28 -0500
 
@@ -105,12 +113,12 @@
   * New upstream release
 
   * debian/control: Set (Build-)Depends: on r-cran-fbasics to (>= 290.76)
-  
+
   * debian/control: Changed Section: to new section 'gnu-r'
-  
+
   * debian/control: Set (Build-)Depends: to current R version
   * debian/control: Set Standards-Version: to current version 3.8.1
-  
+
  -- Dirk Eddelbuettel <edd@debian.org>  Sat, 18 Apr 2009 11:41:24 -0500
 
 fbonds (270.73-1) unstable; urgency=low
@@ -118,7 +126,7 @@
   * New upstream release
 
   * debian/control: Updated (Build-)Depends: and Suggests:
-  
+
   * debian/control: Set (Build-)Depends: to current R version
   * debian/control: Set Standards-Version: to current version
 
@@ -127,7 +135,5 @@
 fbonds (260.72-1) unstable; urgency=low
 
   * Initial Debian release of new Rmetrics component package
-  
+
  -- Dirk Eddelbuettel <edd@debian.org>  Wed, 14 Nov 2007 21:15:24 -0600
-
-

=== removed file 'debian/compat'
--- a/debian/compat	2018-06-05 10:49:09 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-9

=== modified file 'debian/control'
--- a/debian/control	2020-05-17 23:45:13 +0000
+++ b/debian/control	2020-06-11 20:34:23 +0000
@@ -2,7 +2,7 @@
 Section: gnu-r
 Priority: optional
 Maintainer: Dirk Eddelbuettel <edd@debian.org>
-Build-Depends: debhelper (>= 10), r-base-dev (>= 4.0.0), dh-r, r-cran-fbasics (>= 290.76), xvfb, xauth, xfonts-base
+Build-Depends: debhelper-compat (= 12), r-base-dev (>= 4.0.0), dh-r, r-cran-fbasics (>= 290.76), xvfb, xauth, xfonts-base
 Standards-Version: 4.5.0
 Vcs-Browser: https://salsa.debian.org/edd/r-cran-fbonds
 Vcs-Git: https://salsa.debian.org/edd/r-cran-fbonds.git
@@ -18,4 +18,3 @@
  Diethelm Wuertz and others.
  .
  fBonds provides modelling functions for bonds and interest rate models.
-

Run locally

Try this locally (using the lintian-brush package):

debcheckout fbonds
cd fbonds
lintian-brush

More details

Full run details