Lintian Fixes - fimport

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/fimport lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2020-05-17 13:49:30 +0000
+++ b/debian/changelog	2020-06-04 21:38:13 +0000
@@ -1,3 +1,11 @@
+fimport (3042.85-4) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from deprecated 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 04 Jun 2020 21:36:39 -0000
+
 fimport (3042.85-3) unstable; urgency=medium
 
   * Rebuilt for r-4.0 transition
@@ -10,10 +18,10 @@
 fimport (3042.85-2) unstable; urgency=medium
 
   * Rebuilding for R 3.5.0 transition
-  
+
   * debian/control: Set Build-Depends: to current R version
   * debian/control: Set Build-Depends: to 'debhelper (>= 10)'
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
   * debian/control: Add Vcs-Browser: and Vcs-Git:
   * debian/control: Switch from cdbs to dh-r
   * debian/rules: Idem
@@ -29,9 +37,9 @@
 fimport (3042.84-1) unstable; urgency=medium
 
   * New upstream release
-  
-  * debian/control: Set Standards-Version: to current version 
-  * debian/control: Set Build-Depends: to current R version 
+
+  * debian/control: Set Standards-Version: to current version
+  * debian/control: Set Build-Depends: to current R version
   * debianb/control: Add Depends: on ${misc:Depends}
   * debian/compat: Set level to 9
 
@@ -40,18 +48,18 @@
 fimport (3000.82-3) unstable; urgency=medium
 
   * debian/compat: Created			(Closes: #829412)
- 
+
   * debian/control: Set Build-Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
   * inst/perl/html-parser/: Patched two files to use /usr/bin/env
-  
+
  -- Dirk Eddelbuettel <edd@debian.org>  Thu, 07 Jul 2016 05:37:40 -0500
 
 fimport (3000.82-2) unstable; urgency=low
 
-  * debian/control: Set Build-Depends: to current R version 
-  
+  * debian/control: Set Build-Depends: to current R version
+
   * (Re-)building with R 3.0.0
 
  -- Dirk Eddelbuettel <edd@debian.org>  Wed, 03 Apr 2013 05:50:21 -0500
@@ -61,7 +69,7 @@
   * New upstream release
 
   * debian/control: Set Build-Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Fri, 15 Mar 2013 11:11:41 -0500
 
@@ -71,7 +79,7 @@
 
   * debian/control: Set Build-Depends: to current R version
   * debian/control: Change Depends to ${R:Depends}
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Tue, 20 Mar 2012 11:04:43 -0500
 
@@ -80,7 +88,7 @@
   * Rebuilt for R 2.14.0 so that a default NAMESPACE file is created
 
   * debian/control: Set (Build-)Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Sun, 23 Oct 2011 15:30:00 -0500
 
@@ -89,7 +97,7 @@
   * debian/control: Added Depends: on lynx		(Closes: #584612)
 
   * debian/control: Set (Build-)Depends: to current R version
-  
+
  -- Dirk Eddelbuettel <edd@debian.org>  Fri, 04 Jun 2010 22:02:21 -0500
 
 fimport (2110.79-1) unstable; urgency=low
@@ -97,7 +105,7 @@
   * New upstream release
 
   * debian/control: Set (Build-)Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Wed, 14 Apr 2010 18:42:33 -0500
 
@@ -122,7 +130,7 @@
   * New upstream release
 
   * debian/control: Set (Build-)Depends: to current R version
-  * debian/control: Set Standards-Version: to current version 
+  * debian/control: Set Standards-Version: to current version
 
  -- Dirk Eddelbuettel <edd@debian.org>  Wed, 30 Sep 2009 19:36:30 -0500
 
@@ -131,7 +139,7 @@
   * New upstream release
 
   * debian/control: Changed Section: to new section 'gnu-r'
-  
+
   * debian/control: Set (Build-)Depends: to current R version
   * debian/control: Set Standards-Version: to current version 3.8.1
 
@@ -157,7 +165,7 @@
 
   * debian/control: Add (Build-)Depends: on new package r-cran-timeseries
   * debian/control: Updated Suggests:
-  
+
   * debian/control: Set (Build-)Depends: to current R version
   * debian/control: Set Standards-Version: to current version
 
@@ -168,7 +176,5 @@
 fimport (260.72-1) unstable; urgency=low
 
   * Initial Debian release of new Rmetrics component package
-  
+
  -- Dirk Eddelbuettel <edd@debian.org>  Thu, 18 Oct 2007 21:13:27 -0500
-
-

=== removed file 'debian/compat'
--- a/debian/compat	2018-06-03 14:27:14 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-9

=== modified file 'debian/control'
--- a/debian/control	2020-05-17 13:49:30 +0000
+++ b/debian/control	2020-06-04 21:38:13 +0000
@@ -2,7 +2,7 @@
 Section: gnu-r
 Priority: optional
 Maintainer: Dirk Eddelbuettel <edd@debian.org>
-Build-Depends: debhelper (>= 10), r-base-dev (>= 4.0.0), dh-r, r-cran-timeseries, xvfb, xauth, xfonts-base
+Build-Depends: debhelper-compat (= 12), r-base-dev (>= 4.0.0), dh-r, r-cran-timeseries, xvfb, xauth, xfonts-base
 Standards-Version: 4.5.0
 Vcs-Browser: https://salsa.debian.org/edd/r-cran-fimport
 Vcs-Git: https://salsa.debian.org/edd/r-cran-fimport.git
@@ -10,14 +10,13 @@
 
 Package: r-cran-fimport
 Architecture: all
-Depends: ${R:Depends}, ${misc:Depends}, r-cran-timeseries, lynx 
+Depends: ${R:Depends}, ${misc:Depends}, r-cran-timeseries, lynx
 Suggests: r-cran-runit
 Description: GNU R package for financial engineering -- fImport
  This package provides functions to import financial and economic data
  series import and is part of Rmetrics, a collection of packages for
- financial engineering and computational finance written and compiled 
+ financial engineering and computational finance written and compiled
  by Diethelm Wuertz and others.
  .
  fImport provides import function to access (free) data from Economagic,
  the US Federal Reserve, Forecasts.Org, Yahoo and other web sources.
-

Run locally

Try this locally (using the lintian-brush package):

debcheckout fimport
cd fimport
lintian-brush

More details

Full run details