Lintian Fixes - fonts-ipafont-nonfree-jisx0208

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/fonts-ipafont-nonfree-jisx0208 lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2017-10-14 23:44:35 +0000
+++ b/debian/changelog	2019-09-28 14:07:00 +0000
@@ -1,3 +1,11 @@
+fonts-ipafont-nonfree-jisx0208 (1:00103-8) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Use secure copyright file specification URI.
+  * Bump debhelper from old 10 to 12.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 28 Sep 2019 14:06:26 +0000
+
 fonts-ipafont-nonfree-jisx0208 (1:00103-7) unstable; urgency=medium
 
   * debian/control
@@ -5,7 +13,7 @@
     - set Priority: optional since extra is obsoleted
     - set Standards-Version: 4.1.1
   * debian/copyright
-    - use https for Upstream-Contact: 
+    - use https for Upstream-Contact:
 
  -- Hideki Yamane <henrich@debian.org>  Sun, 15 Oct 2017 08:44:32 +0900
 
@@ -15,7 +23,7 @@
     - Build-Depends: debhelper (>= 10)
     - set Standards-Version: 4.0.0
   * debian/compat
-    - set 10 
+    - set 10
   * drop unused debian/fonts-ipafont-nonfree-jisx0208.lintian-overrides
   * drop unnecessary debian/source/lintian-overrides
 
@@ -23,14 +31,14 @@
 
 fonts-ipafont-nonfree-jisx0208 (1:00103-5) unstable; urgency=medium
 
-  * fix regression in debian/fonts-ipafont-nonfree-jisx0208.preinst 
+  * fix regression in debian/fonts-ipafont-nonfree-jisx0208.preinst
 
  -- Hideki Yamane <henrich@debian.org>  Sun, 03 Jan 2016 16:42:02 +0900
 
 fonts-ipafont-nonfree-jisx0208 (1:00103-4) unstable; urgency=medium
 
   * debian/control
-    - update Vcs-Git 
+    - update Vcs-Git
   * debian/fonts-ipafont-nonfree-jisx0208.preinst
     - fix command-with-path-in-maintainer-script
 
@@ -45,7 +53,7 @@
 
   [ Hideki Yamane ]
   * debian/control
-    - set Standards-Version: 3.9.6 
+    - set Standards-Version: 3.9.6
 
  -- Hideki Yamane <henrich@debian.org>  Sat, 24 Jan 2015 21:29:59 +0900
 
@@ -54,7 +62,7 @@
   * debian/control
     - make it Multi-Arch: foreign
     - set Standards-Version: 3.9.4
-    - use git for Vcs-* 
+    - use git for Vcs-*
     - drop obsolete ttf- package
 
  -- Hideki Yamane <henrich@debian.org>  Sun, 16 Jun 2013 03:48:48 +0900
@@ -112,7 +120,7 @@
     - set "Conflicts: ttf-ipafont-jisx0208 (<< 00103-17)" and also "Replaces:"
     - fix typo in description (Closes: LP#836596)
   * debian/fonts-ipafont-nonfree-jisx0208.{pre,post}inst,prerm
-    - use fonts-japanese-{gothic,mincho}.ttf, instead of 
+    - use fonts-japanese-{gothic,mincho}.ttf, instead of
       ttf-japanese-{gothic,mincho}.ttf
   * remove debian/watch file since upstream don't provide the file anymore.
 
@@ -147,7 +155,7 @@
     - set "Standards-Version: 3.8.4"
     - change from "Recommends: ttf-ipafont" to "Suggests: otf-ipafont"
   * debian/watch
-    - update to deal with upstream's change 
+    - update to deal with upstream's change
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sat, 06 Mar 2010 21:16:41 +0900
 
@@ -169,13 +177,13 @@
 
   * debian/prerm: remove fc-cache
   * debian/control:
-    - set "Standards-Version: 3.8.2" 
+    - set "Standards-Version: 3.8.2"
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sat, 20 Jun 2009 16:23:48 +0900
 
 ttf-ipafont-jisx0208 (00103-10) unstable; urgency=low
 
-  * debian/postinst: remove fc-cache 
+  * debian/postinst: remove fc-cache
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Wed, 17 Jun 2009 04:20:00 +0900
 
@@ -203,19 +211,19 @@
 
 ttf-ipafont-jisx0208 (00103-6) unstable; urgency=low
 
-  * debian/ttf-ipafont-jisx0208.defoma-hints: fix pathname. 
+  * debian/ttf-ipafont-jisx0208.defoma-hints: fix pathname.
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sun, 31 May 2009 22:09:21 +0900
 
 ttf-ipafont-jisx0208 (00103-5) unstable; urgency=low
 
-  * fix broken alternative symlink. 
+  * fix broken alternative symlink.
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sun, 17 May 2009 00:49:23 +0900
 
 ttf-ipafont-jisx0208 (00103-4) unstable; urgency=low
 
-  * debian/watch: fix it 
+  * debian/watch: fix it
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Thu, 14 May 2009 05:08:10 +0900
 
@@ -229,7 +237,7 @@
 ttf-ipafont-jisx0208 (00103-2) unstable; urgency=low
 
   * debian/control:
-    - new section "fonts" 
+    - new section "fonts"
     - fix Vcs-Svn and Vcs-Browser fields.
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sun, 10 May 2009 02:53:48 +0900
@@ -239,13 +247,13 @@
   * New upstream release
   * Upload to Official Debian repository (closes: #471014)
   * debian/control
-    - use Build-Depends-Indep: field for defoma, not Build-Depends:. 
+    - use Build-Depends-Indep: field for defoma, not Build-Depends:.
       Thanks to lintian.
     - Suggests: xfs (>= 1:1.0.1-5)
     - add "DM-Upload-Allowed: yes"
   * debian/copyright
     - change English license text from gentoo people, thanks!
-      see http://bugs.gentoo.org/196340 
+      see http://bugs.gentoo.org/196340
   * add alternatives support
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Thu, 12 Mar 2009 13:34:24 +0900
@@ -255,4 +263,3 @@
   * Initial release.
 
  -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sun, 17 Feb 2008 20:09:29 +0900
-

=== removed file 'debian/compat'
--- a/debian/compat	2017-07-27 14:31:11 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-10

=== modified file 'debian/control'
--- a/debian/control	2017-10-14 23:44:15 +0000
+++ b/debian/control	2019-09-28 14:07:00 +0000
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian Fonts Task Force <pkg-fonts-devel@lists.alioth.debian.org>
 Uploaders: Hideki Yamane <henrich@debian.org>
-Build-Depends: debhelper (>= 10)
+Build-Depends: debhelper-compat (= 12)
 Standards-Version: 4.1.1
 Homepage: https://www.ipa.go.jp/
 Vcs-Git: https://anonscm.debian.org/git/pkg-fonts/fonts-ipafont-nonfree-jisx0208.git
@@ -29,8 +29,7 @@
   * IPA Mincho
   * IPA P Mincho
  .
- It based on JISX0208 specifications. fonts-ipafont package is based on new 
- JISX0214, has different glyphs on some same characters. So this package 
- contains glyphs that have compatibility with old specifications, such as MS 
+ It based on JISX0208 specifications. fonts-ipafont package is based on new
+ JISX0214, has different glyphs on some same characters. So this package
+ contains glyphs that have compatibility with old specifications, such as MS
  Gothic or Mincho fonts or so. That is important thing for business documents.
-

=== modified file 'debian/copyright'
--- a/debian/copyright	2017-10-14 23:43:02 +0000
+++ b/debian/copyright	2019-09-28 14:06:45 +0000
@@ -1,4 +1,4 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
 Upstream-Name: IPAfont
 Upstream-Contact: https://www.ipa.go.jp
 Source: http://ossipedia.ipa.go.jp/ipafont/download.php (however, obsolete)

Run locally

Try this locally (using the lintian-brush package):

debcheckout fonts-ipafont-nonfree-jisx0208
cd fonts-ipafont-nonfree-jisx0208
lintian-brush

More details

Full run details