Lintian Fixes - globus-openssl-module

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/globus-openssl-module lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2019-07-15 12:49:16 +0000
+++ b/debian/changelog	2020-06-06 16:03:08 +0000
@@ -1,3 +1,12 @@
+globus-openssl-module (5.1-3) UNRELEASED; urgency=low
+
+  * Bump debhelper from old 10 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 06 Jun 2020 16:00:52 -0000
+
 globus-openssl-module (5.1-2) unstable; urgency=medium
 
   * Convert debian/rules to dh tool

=== removed file 'debian/compat'
--- a/debian/compat	2019-07-15 12:49:16 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-10

=== modified file 'debian/control'
--- a/debian/control	2019-07-15 12:49:16 +0000
+++ b/debian/control	2020-06-06 16:03:08 +0000
@@ -2,14 +2,14 @@
 Priority: optional
 Maintainer: Mattias Ellert <mattias.ellert@physics.uu.se>
 Build-Depends:
- debhelper (>= 10),
+ debhelper-compat (= 12),
  pkg-config,
  libglobus-common-dev (>= 15),
  libglobus-gsi-proxy-ssl-dev (>= 4),
  libglobus-gsi-openssl-error-dev (>= 2),
  libssl-dev,
  doxygen
-Standards-Version: 4.4.0
+Standards-Version: 4.5.0
 Section: net
 Vcs-Browser: https://salsa.debian.org/ellert/globus-openssl-module
 Vcs-Git: https://salsa.debian.org/ellert/globus-openssl-module.git

=== added directory 'debian/upstream'
=== added file 'debian/upstream/metadata'
--- a/debian/upstream/metadata	1970-01-01 00:00:00 +0000
+++ b/debian/upstream/metadata	2020-06-06 16:02:31 +0000
@@ -0,0 +1,3 @@
+---
+Bug-Database: https://github.com/gridcf/gct/issues
+Bug-Submit: https://github.com/gridcf/gct/issues/new

Run locally

Try this locally (using the lintian-brush package):

debcheckout globus-openssl-module
cd globus-openssl-module
lintian-brush

More details

Full run details