Lintian Fixes - ivy

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/ivy lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2018-06-13 21:58:03 +0000
+++ b/debian/changelog	2020-06-07 23:31:36 +0000
@@ -1,3 +1,11 @@
+ivy (2.4.0-6) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sun, 07 Jun 2020 23:30:03 -0000
+
 ivy (2.4.0-5) unstable; urgency=medium
 
   * Team upload.
@@ -81,7 +89,7 @@
 ivy (2.3.0-1) experimental; urgency=low
 
   [ Miguel Landaeta ]
-  * New upstream release. 
+  * New upstream release.
   * Bump Standards-Version to 3.9.4. No changes were required.
   * Fix minor lintian warning regarding package description.
 

=== removed file 'debian/compat'
--- a/debian/compat	2018-06-13 17:06:48 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-11

=== modified file 'debian/control'
--- a/debian/control	2018-06-13 17:08:32 +0000
+++ b/debian/control	2020-06-07 23:31:36 +0000
@@ -9,7 +9,7 @@
  Emmanuel Bourg <ebourg@apache.org>
 Build-Depends:
  ant,
- debhelper (>= 11~),
+ debhelper-compat (= 12),
  default-jdk,
  default-jdk-doc,
  junit,

Run locally

Try this locally (using the lintian-brush package):

debcheckout ivy
cd ivy
lintian-brush --exclude=upstream-metadata-file

More details

Full run details