Lintian Fixes - junixsocket

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/junixsocket lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2018-11-27 22:44:18 +0000
+++ b/debian/changelog	2020-06-05 15:43:31 +0000
@@ -1,3 +1,10 @@
+junixsocket (2.0.4-2) UNRELEASED; urgency=low
+
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Fri, 05 Jun 2020 15:42:38 -0000
+
 junixsocket (2.0.4-1) unstable; urgency=medium
 
   * Initial release (Closes: #914849)

=== removed file 'debian/compat'
--- a/debian/compat	2018-11-27 22:44:18 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-11

=== modified file 'debian/control'
--- a/debian/control	2018-11-27 22:44:18 +0000
+++ b/debian/control	2020-06-05 15:43:31 +0000
@@ -4,7 +4,7 @@
 Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
 Uploaders: Emmanuel Bourg <ebourg@apache.org>
 Build-Depends:
- debhelper (>= 11),
+ debhelper-compat (= 12),
  default-jdk,
  libmaven-shade-plugin-java,
  maven-debian-helper (>= 2.1)

Run locally

Try this locally (using the lintian-brush package):

debcheckout junixsocket
cd junixsocket
lintian-brush --exclude=upstream-metadata-file

More details

Full run details