Lintian Fixes - lua-cyrussasl

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/lua-cyrussasl lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2019-07-15 15:50:11 +0000
+++ b/debian/changelog	2020-04-06 21:37:37 +0000
@@ -1,3 +1,16 @@
+lua-cyrussasl (1.1.0-2) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Use secure copyright file specification URI.
+  * Use secure URI in Homepage field.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+    Repository-Browse.
+  * Update standards version to 4.4.1, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 06 Apr 2020 21:34:21 +0000
+
 lua-cyrussasl (1.1.0-1) unstable; urgency=medium
 
   * New upstream version, compatible with Lua 5.1, 5.2 and 5.3
@@ -29,17 +42,17 @@
 lua-cyrussasl (1.0.0-5) unstable; urgency=low
 
   * Package moved to git
-  * Transitional packages removed 
+  * Transitional packages removed
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Thu, 19 Apr 2012 11:58:13 +0200
 
 lua-cyrussasl (1.0.0-4) unstable; urgency=low
 
   * debian/compat set to 8
-  * Copyright format 1.0 
+  * Copyright format 1.0
   * Packages renamed according to the new Lua policy
   * Switch to dh-lua
-  * Updated standards-version to 3.9.3, no changes 
+  * Updated standards-version to 3.9.3, no changes
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Thu, 19 Apr 2012 11:51:51 +0200
 

=== removed file 'debian/compat'
--- a/debian/compat	2019-07-15 13:49:05 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-11

=== modified file 'debian/control'
--- a/debian/control	2019-07-15 15:50:11 +0000
+++ b/debian/control	2020-04-06 21:37:37 +0000
@@ -3,9 +3,9 @@
 Priority: optional
 Maintainer: Enrico Tassi <gareuselesinge@debian.org>
 Uploaders: Sergei Golovan <sgolovan@debian.org>
-Build-Depends: debhelper (>= 11), dh-lua (>= 12), libsasl2-dev
-Standards-Version: 4.4.0
-Homepage: http://github.com/JorjBauer/lua-cyrussasl
+Build-Depends: debhelper-compat (= 12), dh-lua (>= 12), libsasl2-dev
+Standards-Version: 4.4.1
+Homepage: https://github.com/JorjBauer/lua-cyrussasl
 Vcs-Browser: https://salsa.debian.org/lua-team/lua-cyrussasl
 Vcs-Git: https://salsa.debian.org/lua-team/lua-cyrussasl.git
 

=== modified file 'debian/copyright'
--- a/debian/copyright	2019-07-15 15:50:11 +0000
+++ b/debian/copyright	2020-04-06 21:35:03 +0000
@@ -1,4 +1,4 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
 Upstream-Name: lua-cyrussasl
 Upstream-Contact: Jorj Bauer <jorj@jorj.org>
 Source: http://github.com/JorjBauer/lua-cyrussasl

=== added directory 'debian/upstream'
=== added file 'debian/upstream/metadata'
--- a/debian/upstream/metadata	1970-01-01 00:00:00 +0000
+++ b/debian/upstream/metadata	2020-04-06 21:37:08 +0000
@@ -0,0 +1,4 @@
+Bug-Database: https://github.com/JorjBauer/lua-cyrussasl/issues
+Bug-Submit: https://github.com/JorjBauer/lua-cyrussasl/issues/new
+Repository: https://github.com/JorjBauer/lua-cyrussasl.git
+Repository-Browse: https://github.com/JorjBauer/lua-cyrussasl

Run locally

Try this locally (using the lintian-brush package):

debcheckout lua-cyrussasl
cd lua-cyrussasl
lintian-brush

More details

Full run details