Lintian Fixes - lua-sql

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/lua-sql lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2017-01-04 21:26:01 +0000
+++ b/debian/changelog	2020-06-30 19:18:40 +0000
@@ -1,8 +1,19 @@
+lua-sql (2.3.4-2) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from deprecated 8 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+    Repository-Browse.
+  * Update Vcs-* headers to use salsa repository.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Tue, 30 Jun 2020 19:15:23 -0000
+
 lua-sql (2.3.4-1) unstable; urgency=medium
 
   * New upstream bugfix release
-  * Update watch file 
-  * Enable build for Lua 5.3 
+  * Update watch file
+  * Enable build for Lua 5.3
   * Enable ODBC backend (packaging sponsored by Apartment Lines)
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Tue, 03 Jan 2017 18:58:50 +0100
@@ -24,21 +35,21 @@
 
 lua-sql (2.3.0-3) unstable; urgency=low
 
-  * Fix compilation with postgresql 9.3 
+  * Fix compilation with postgresql 9.3
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Wed, 18 Sep 2013 20:04:39 +0200
 
 lua-sql (2.3.0-2) unstable; urgency=low
 
   * Packaging moved to git
-  * Transitional packages removed 
+  * Transitional packages removed
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Thu, 24 May 2012 18:00:04 +0200
 
 lua-sql (2.3.0-1) unstable; urgency=low
 
   * New upstream release
-  * Fix watch file 
+  * Fix watch file
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Mon, 30 Apr 2012 16:26:50 +0200
 
@@ -48,28 +59,28 @@
   * Switch to dh-lua
   * debian/compat set to 8
   * Packages renamed according to the new Lua policy
-  * copyright format 1.0 
+  * copyright format 1.0
   * disable patches/test
-  * watch file updated 
+  * watch file updated
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Mon, 30 Apr 2012 16:16:45 +0200
 
 lua-sql (2.2.0~rc1-5) unstable; urgency=low
 
-  * build-dep on libmysqlclient-dev instead of libmysqlclient15-dev 
+  * build-dep on libmysqlclient-dev instead of libmysqlclient15-dev
     (Closes: #650597)
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Sat, 03 Dec 2011 14:59:34 +0100
 
 lua-sql (2.2.0~rc1-4) unstable; urgency=low
 
-  * multi-arch compliant (dh >= 8.1.3, lua5.1-policy >= 32) 
+  * multi-arch compliant (dh >= 8.1.3, lua5.1-policy >= 32)
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Wed, 20 Jul 2011 23:22:55 +0200
 
 lua-sql (2.2.0~rc1-3) unstable; urgency=low
 
-  * Rebuild against lua5.1-policy-dev >= 27 to get rid of .la (Closes: #622500) 
+  * Rebuild against lua5.1-policy-dev >= 27 to get rid of .la (Closes: #622500)
   * Update Standards-version to 3.9.2, no changes
   * Version 3.0 (quilt)
 

=== removed file 'debian/compat'
--- a/debian/compat	2012-04-30 14:17:48 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-8

=== modified file 'debian/control'
--- a/debian/control	2017-01-03 09:05:47 +0000
+++ b/debian/control	2020-06-30 19:18:40 +0000
@@ -2,11 +2,11 @@
 Section: interpreters
 Priority: optional
 Maintainer: Enrico Tassi <gareuselesinge@debian.org>
-Build-Depends: debhelper (>= 8.1.3), dh-lua, default-libmysqlclient-dev, libsqlite3-dev, libpq-dev, unixodbc-dev
+Build-Depends: debhelper-compat (= 12), dh-lua, default-libmysqlclient-dev, libsqlite3-dev, libpq-dev, unixodbc-dev
 Standards-Version: 3.9.3
-Vcs-Svn: svn://svn.debian.org/pkg-lua/packages/lua-sql
-Vcs-Browser: http://svn.debian.org/viewsvn/pkg-lua/packages/lua-sql
+Vcs-Browser: https://salsa.debian.org/gareuselesinge/lua-sql
 Homepage: https://github.com/keplerproject/luasql
+Vcs-Git: https://salsa.debian.org/gareuselesinge/lua-sql.git
 
 Package: lua-sql-sqlite3
 Architecture: any
@@ -28,7 +28,7 @@
 XB-Lua-Versions: ${lua:Versions}
 Description: luasql development files for the Lua language
  This package contains the development files of the luasql library
- (Sqlite3 backend), useful to create a statically linked binary 
+ (Sqlite3 backend), useful to create a statically linked binary
  (like a C application or a standalone Lua interpreter).
 
 Package: lua-sql-postgres
@@ -51,7 +51,7 @@
 XB-Lua-Versions: ${lua:Versions}
 Description: luasql development files for the Lua language
  This package contains the development files of the luasql library
- (PostgreSQL backend), useful to create a statically linked binary 
+ (PostgreSQL backend), useful to create a statically linked binary
  (like a C application or a standalone Lua interpreter).
 
 Package: lua-sql-mysql
@@ -73,8 +73,8 @@
 Provides: ${lua:Provides}
 XB-Lua-Versions: ${lua:Versions}
 Description: luasql development files for the Lua language
- This package contains the development files of the luasql library 
- (MySQL backend), useful to create a statically linked binary 
+ This package contains the development files of the luasql library
+ (MySQL backend), useful to create a statically linked binary
  (like a C application or a standalone Lua interpreter).
 
 Package: lua-sql-odbc
@@ -96,8 +96,8 @@
 Provides: ${lua:Provides}
 XB-Lua-Versions: ${lua:Versions}
 Description: luasql development files for the Lua language
- This package contains the development files of the luasql library 
- (ODBC backend), useful to create a statically linked binary 
+ This package contains the development files of the luasql library
+ (ODBC backend), useful to create a statically linked binary
  (like a C application or a standalone Lua interpreter).
 
 Package: lua-sql-doc
@@ -105,4 +105,4 @@
 Section: doc
 Depends: ${misc:Depends}
 Description: luasql documentation
- This package contains the documentation of the luasql library. 
+ This package contains the documentation of the luasql library.

=== added directory 'debian/upstream'
=== added file 'debian/upstream/metadata'
--- a/debian/upstream/metadata	1970-01-01 00:00:00 +0000
+++ b/debian/upstream/metadata	2020-06-30 19:17:50 +0000
@@ -0,0 +1,5 @@
+---
+Bug-Database: https://github.com/keplerproject/luasql/issues
+Bug-Submit: https://github.com/keplerproject/luasql/issues/new
+Repository: https://github.com/keplerproject/luasql.git
+Repository-Browse: https://github.com/keplerproject/luasql

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/lib/debug/.dwz/x86_64-linux-gnu/lua-sql-mysql.debug
-rw-r--r--  root/root   /usr/lib/debug/.dwz/x86_64-linux-gnu/lua-sql-odbc.debug
-rw-r--r--  root/root   /usr/lib/debug/.dwz/x86_64-linux-gnu/lua-sql-postgres.debug
-rw-r--r--  root/root   /usr/lib/debug/.dwz/x86_64-linux-gnu/lua-sql-sqlite3.debug

No differences were encountered between the control files of package lua-sql-doc

No differences were encountered between the control files of package lua-sql-mysql

No differences were encountered between the control files of package lua-sql-mysql-dbgsym

No differences were encountered between the control files of package lua-sql-mysql-dev

No differences were encountered between the control files of package lua-sql-odbc

No differences were encountered between the control files of package lua-sql-odbc-dbgsym

No differences were encountered between the control files of package lua-sql-odbc-dev

No differences were encountered between the control files of package lua-sql-postgres

No differences were encountered between the control files of package lua-sql-postgres-dbgsym

No differences were encountered between the control files of package lua-sql-postgres-dev

No differences were encountered between the control files of package lua-sql-sqlite3

No differences were encountered between the control files of package lua-sql-sqlite3-dbgsym

No differences were encountered between the control files of package lua-sql-sqlite3-dev

Run locally

Try this locally (using the lintian-brush package):

debcheckout lua-sql
cd lua-sql
lintian-brush

More details

Full run details