Lintian Fixes - php-oauth

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/php-oauth lintian-fixes

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2019-08-28 07:20:38 +0000
+++ b/debian/changelog	2019-12-12 05:28:24 +0000
@@ -1,3 +1,16 @@
+php-oauth (2.0.3+1.2.3-3) UNRELEASED; urgency=medium
+
+  * Use secure copyright file specification URI.
+  * Use secure URI in debian/watch.
+  * Use secure URI in Homepage field.
+  * Bump debhelper from old 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Change priority extra to priority optional.
+  * debian/copyright: use spaces rather than tabs to start continuation
+    lines.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 12 Dec 2019 05:26:06 +0000
+
 php-oauth (2.0.3+1.2.3-2) unstable; urgency=medium
 
   * No change rebuild for Debian buster

=== removed file 'debian/compat'
--- a/debian/compat	2013-05-28 07:55:04 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-9

=== modified file 'debian/control'
--- a/debian/control	2018-12-17 10:22:45 +0000
+++ b/debian/control	2019-12-12 05:28:04 +0000
@@ -1,15 +1,15 @@
 Source: php-oauth
 Section: php
-Priority: extra
+Priority: optional
 Maintainer: Debian PHP PECL Maintainers <team+php-pecl@tracker.debian.org>
 Uploaders: Prach Pongpanich <prachpub@gmail.com>,
            Ondřej Surý <ondrej@debian.org>
-Build-Depends: debhelper (>= 9~),
+Build-Depends: debhelper-compat (= 12),
                dh-php (>= 0.33~),
                libpcre3-dev,
                php-all-dev
 Standards-Version: 3.9.8
-Homepage: http://pecl.php.net/package/oauth
+Homepage: https://pecl.php.net/package/oauth
 Vcs-Browser: https://salsa.debian.org/php-team/pecl/php-oauth
 Vcs-Git: https://salsa.debian.org/php-team/pecl/php-oauth.git
 

=== modified file 'debian/copyright'
--- a/debian/copyright	2013-10-21 09:05:19 +0000
+++ b/debian/copyright	2019-12-12 05:28:24 +0000
@@ -1,9 +1,9 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
 Upstream-Name: OAuth 1.0 consumer and provider extension
 Upstream-Contact: John Jawed <jawed@php.net>
-		  Felipe Pena <felipe@php.net>
-		  Rasmus Lerdorf <rasmus@php.net>
-		  Tjerk Meesters <datibbaw@php.net>
+ 		  Felipe Pena <felipe@php.net>
+ 		  Rasmus Lerdorf <rasmus@php.net>
+ 		  Tjerk Meesters <datibbaw@php.net>
 Source: http://pecl.php.net/package/oauth
 
 Files: *

=== modified file 'debian/watch'
--- a/debian/watch	2013-12-23 03:42:34 +0000
+++ b/debian/watch	2019-12-12 05:26:45 +0000
@@ -1,3 +1,3 @@
 version=3
-http://pecl.php.net/package/oauth \
+https://pecl.php.net/package/oauth \
   /get/oauth-([\d\.p?]*).tgz  debian  uupdate

Run locally

Try this locally (using the lintian-brush package):

debcheckout php-oauth
cd php-oauth
lintian-brush

More details

Full run details