Run of fresh-snapshots for adwaita-icon-theme

Try this locally package):


git clone  adwaita-icon-theme
cd adwaita-icon-theme
ogni dist

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Using upstream branch https://gitlab.gnome.org/GNOME/adwaita-icon-theme.git (guessed)
Total 146 (delta 51), reused 146 (delta 51), pack-reused 0
Using version string 42.beta+git20220304.1.1380da5.
No upstream upstream-revision format specified, trying tag:42~beta
No upstream upstream-revision format specified, trying tag:adwaita-icon-theme-42~beta
No upstream upstream-revision format specified, trying tag:v42~beta
No upstream upstream-revision format specified, trying tag:v.42~beta
No upstream upstream-revision format specified, trying tag:release-42~beta
No upstream upstream-revision format specified, trying tag:42~beta_release
No upstream upstream-revision format specified, trying tag:42~beta
No upstream upstream-revision format specified, trying tag:version-42~beta
No upstream upstream-revision format specified, trying tag:adwaita-icon-theme-42~beta-release
No upstream upstream-revision format specified, trying tag:adwaita-icon-theme-v42~beta
Old upstream version '42~beta' is not present in upstream branch <UpstreamBranchSource for 'https://gitlab.gnome.org/GNOME/adwaita-icon-theme.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
Looking for upstream 42.beta+git20220304.1.1380da5 in upstream branch <RemoteGitBranch('https://gitlab.gnome.org/GNOME/adwaita-icon-theme.git/', 'master')>.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python39.zip:/usr/lib/python3.9:/usr/lib/python3.9/lib-dynload:/usr/local/lib/python3.9/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitorgt5xa6pi/adwaita-icon-theme/debian
Opened schroot session unstable-amd64-sbuild-8bf4676d-471c-4c2e-b833-fd4aa96961e7 (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n               dh-sequence-gnome', 'gettext,\n                     pkg-config,\n                     libgtk-3-bin (>= 3.24.13),\n                     librsvg2-bin,\n                     librsvg2-common:native']
Traceback (most recent call last):
  File "/usr/lib/python3.9/runpy.py", line 197, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/lib/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/code/janitor/dist.py", line 128, in <module>
    satisfy_build_deps(session, packaging_tree, packaging_debian_path)
  File "/code/ognibuild/ognibuild/debian/__init__.py", line 41, in satisfy_build_deps
    apt.satisfy(deps)
  File "/code/ognibuild/ognibuild/debian/apt.py", line 132, in satisfy
    run_apt(self.session, ["satisfy"] + deps, prefix=self.prefix)
  File "/code/ognibuild/ognibuild/debian/apt.py", line 49, in run_apt
    match, error = find_apt_get_failure(lines.rstrip('\n'))
AttributeError: 'list' object has no attribute 'rstrip'
Command 'SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python39.zip:/usr/lib/python3.9:/usr/lib/python3.9/lib-dynload:/usr/local/lib/python3.9/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitorgt5xa6pi/adwaita-icon-theme/debian' returned non-zero exit status 1.

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=leave deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far. not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 1195, max open: 200)
  • ☒ change set eaab6ac3-505d-4b7c-b40b-7ceceac215ae is working

Full worker log