Run of scrub-obsolete for avahi

Try this locally (using the lintian-brush package):

debcheckout avahi
cd avahi
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/avahi scrub-obsolete/main

Diff

diff --git a/debian/control b/debian/control
index add27a0..948b9ff 100644
--- a/debian/control
+++ b/debian/control
@@ -24,7 +24,7 @@ Build-Depends: debhelper-compat (= 12),
                gobject-introspection,
                libgirepository1.0-dev,
                xmltoman,
-               intltool (>= 0.35.0)
+               intltool
 Rules-Requires-Root: no
 Standards-Version: 4.5.0
 Vcs-Git: https://salsa.debian.org/utopia-team/avahi.git
@@ -37,7 +37,7 @@ Pre-Depends: ${misc:Pre-Depends}
 Depends: ${shlibs:Depends},
          ${misc:Depends},
          adduser,
-         dbus (>= 0.60),
+         dbus,
          lsb-base (>= 3.0-6),
          bind9-host | host
 Recommends: libnss-mdns (>= 0.11),

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package avahi-autoipd

No differences were encountered between the control files of package avahi-autoipd-dbgsym

Control files of package avahi-daemon: lines which differ (wdiff format)

  • Depends: libavahi-common3 (=  libavahi-core7 (=  libc6 (>= 2.27), libcap2 (>= 1:2.16), libdaemon0 (>= 0.14), libdbus-1-3 (>= 1.9.14), libexpat1 (>= 2.0.1), adduser, dbus (>= 0.60), dbus, lsb-base (>= 3.0-6), bind9-host | host

No differences were encountered between the control files of package avahi-daemon-dbgsym

No differences were encountered between the control files of package avahi-discover

No differences were encountered between the control files of package avahi-dnsconfd

No differences were encountered between the control files of package avahi-dnsconfd-dbgsym

No differences were encountered between the control files of package avahi-ui-utils

No differences were encountered between the control files of package avahi-ui-utils-dbgsym

No differences were encountered between the control files of package avahi-utils

No differences were encountered between the control files of package avahi-utils-dbgsym

No differences were encountered between the control files of package gir1.2-avahi-0.6

No differences were encountered between the control files of package libavahi-client-dev

No differences were encountered between the control files of package libavahi-client3

No differences were encountered between the control files of package libavahi-client3-dbgsym

No differences were encountered between the control files of package libavahi-common-data

No differences were encountered between the control files of package libavahi-common-dev

No differences were encountered between the control files of package libavahi-common3

No differences were encountered between the control files of package libavahi-common3-dbgsym

No differences were encountered between the control files of package libavahi-compat-libdnssd-dev

No differences were encountered between the control files of package libavahi-compat-libdnssd1

No differences were encountered between the control files of package libavahi-compat-libdnssd1-dbgsym

No differences were encountered between the control files of package libavahi-core-dev

No differences were encountered between the control files of package libavahi-core7

No differences were encountered between the control files of package libavahi-core7-dbgsym

No differences were encountered between the control files of package libavahi-glib-dev

No differences were encountered between the control files of package libavahi-glib1

No differences were encountered between the control files of package libavahi-glib1-dbgsym

No differences were encountered between the control files of package libavahi-gobject-dev

No differences were encountered between the control files of package libavahi-gobject0

No differences were encountered between the control files of package libavahi-gobject0-dbgsym

No differences were encountered between the control files of package libavahi-ui-gtk3-0

No differences were encountered between the control files of package libavahi-ui-gtk3-0-dbgsym

No differences were encountered between the control files of package libavahi-ui-gtk3-dev

No differences were encountered between the control files of package python3-avahi

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t unstable avahi-autoipd-dbgsym
apt install -t unstable avahi-autoipd
apt install -t unstable avahi-daemon-dbgsym
apt install -t unstable avahi-daemon
apt install -t unstable avahi-discover
apt install -t unstable avahi-dnsconfd-dbgsym
apt install -t unstable avahi-dnsconfd
apt install -t unstable avahi-ui-utils-dbgsym
apt install -t unstable avahi-ui-utils
apt install -t unstable avahi-utils-dbgsym
apt install -t unstable avahi-utils
apt install -t unstable gir1.2-avahi-0.6
apt install -t unstable libavahi-client-dev
apt install -t unstable libavahi-client3-dbgsym
apt install -t unstable libavahi-client3
apt install -t unstable libavahi-common-data
apt install -t unstable libavahi-common-dev
apt install -t unstable libavahi-common3-dbgsym
apt install -t unstable libavahi-common3
apt install -t unstable libavahi-compat-libdnssd-dev
apt install -t unstable libavahi-compat-libdnssd1-dbgsym
apt install -t unstable libavahi-compat-libdnssd1
apt install -t unstable libavahi-core-dev
apt install -t unstable libavahi-core7-dbgsym
apt install -t unstable libavahi-core7
apt install -t unstable libavahi-glib-dev
apt install -t unstable libavahi-glib1-dbgsym
apt install -t unstable libavahi-glib1
apt install -t unstable libavahi-gobject-dev
apt install -t unstable libavahi-gobject0-dbgsym
apt install -t unstable libavahi-gobject0
apt install -t unstable libavahi-ui-gtk3-0-dbgsym
apt install -t unstable libavahi-ui-gtk3-0
apt install -t unstable libavahi-ui-gtk3-dev
apt install -t unstable python3-avahi

Lintian Result

Full worker log Full build log