Run of fresh-snapshots for awl

Try this locally package):

debcheckout awl
cd awl
DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Using upstream branch https://gitlab.com/davical-project/awl.git (from configuration)
Using version string 0.62+git20220213.1.3f044e2.
No upstream upstream-revision format specified, trying tag:0.62
No upstream upstream-revision format specified, trying tag:awl-0.62
No upstream upstream-revision format specified, trying tag:v0.62
No upstream upstream-revision format specified, trying tag:v.0.62
No upstream upstream-revision format specified, trying tag:release-0.62
No upstream upstream-revision format specified, trying tag:0_62_release
No upstream upstream-revision format specified, trying tag:0_62
No upstream upstream-revision format specified, trying tag:version-0.62
No upstream upstream-revision format specified, trying tag:awl-0_62-release
No upstream upstream-revision format specified, trying tag:awl-v0.62
Old upstream version '0.62' is not present in upstream branch <UpstreamBranchSource for 'https://gitlab.com/davical-project/awl.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
Looking for upstream 0.62+git20220213.1.3f044e2 in upstream branch <RemoteGitBranch('https://gitlab.com/davical-project/awl.git/', 'master')>.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python39.zip:/usr/lib/python3.9:/usr/lib/python3.9/lib-dynload:/usr/local/lib/python3.9/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitort0kw3_mw/awl/debian
Opened schroot session unstable-amd64-sbuild-2afd6d84-6c8c-4bd0-89cb-f5ec492bd2d1 (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13), jdupes, doxygen, phpunit']
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, cran, octave-forge]
Running ['make', 'dist']
Build failed with unidentified error:
make: *** No rule to make target 'dist'.  Stop.
Exporting upstream branch revision b'git-v1:3f044e2dc8435c2eeba61a3c41ec11c820711ab3' to create the tarball
Searching for revision importing awl version 0.62 on packaging branch.
Previous upstream version 0.62 missing (tag: upstream/0.62).

Full worker log