Run of lintian-fixes for burgerspace

Try this locally (using the lintian-brush package):

debcheckout burgerspace
cd burgerspace
DEB_UPDATE_CHANGELOG=auto lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/burgerspace lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 63a85fc..9006a1c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+burgerspace (1.9.3-2) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Update watch file format version to 4.
+  * Update standards version to 4.5.1, no changes needed.
+  * Avoid explicitly specifying -Wl,--as-needed linker flag.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 16 Jun 2021 09:03:55 -0000
+
 burgerspace (1.9.3-1) unstable; urgency=medium
 
   * New upstream version 1.9.3.
diff --git a/debian/control b/debian/control
index 957e313..d514afb 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Build-Depends:
  libsdl-mixer1.2-dev,
  libsdl1.2-dev,
  pkg-config
-Standards-Version: 4.4.1
+Standards-Version: 4.5.1
 Homepage: http://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html
 Vcs-Git: https://salsa.debian.org/games-team/burgerspace.git
 Vcs-Browser: https://salsa.debian.org/games-team/burgerspace
diff --git a/debian/rules b/debian/rules
index 5e1e2ed..7908417 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,6 @@
 #!/usr/bin/make -f
 
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
 %:
 	dh $@
@@ -15,4 +14,3 @@ override_dh_auto_install:
 
 override_dh_installchangelogs:
 	dh_installchangelogs NEWS
-
diff --git a/debian/watch b/debian/watch
index 1a27791..1fd3a41 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,2 +1,2 @@
-version=3
+version=4
 http://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html burgerspace-(.*)\.tar\.gz debian uupdate

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package burgerspace

No differences were encountered between the control files of package burgerspace-dbgsym

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t unstable burgerspace-dbgsym
apt install -t unstable burgerspace

Lintian Result

Full worker log Full build log