Run of cme for busybox

Try this locally (using the lintian-brush package):

debcheckout busybox
cd busybox
cme-fix
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
[2021-05-20 16:49:12] Running ['cme-fix']
[2021-05-20 16:49:12] Opening branch at https://salsa.debian.org/installer-team/busybox.git/,branch=master
[2021-05-20 16:49:13] Using cached branch https://janitor.debian.net/git/busybox/,branch=debian%2Flatest
[2021-05-20 16:49:36] Total 106633 (delta 0), reused 0 (delta 0), pack-reused 106628
[2021-05-20 16:49:36] 
[2021-05-20 16:51:30] Total 81 (delta 15), reused 15 (delta 15), pack-reused 61
[2021-05-20 16:51:30] 
[2021-05-20 16:51:34] Total 63 (delta 3), reused 3 (delta 3), pack-reused 58
[2021-05-20 16:51:35] Workspace ready - starting.

Reading package lists... 0%

Reading package lists... 0%

Reading package lists... 0%

Reading package lists... 95%

Reading package lists... 95%

Reading package lists... 95%

Reading package lists... 95%

Reading package lists... 96%

Reading package lists... 96%

Reading package lists... 96%

Reading package lists... 96%

Reading package lists... Done


Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree... 87%

Building dependency tree... Done


Reading state information... 0% 

Reading state information... 0%

Reading state information... Done

Warning in 'control source Standards-Version': Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.1.5' to '4.5.1'.

Offending value: '4.1.5'
Warning in 'control source Build-Depends:0': compat parameter is deprecated. Please use debhelper-compat dependency. See debhelper(7) for details.
Offending value: 'debhelper (>= 11~)'
Warning in 'control source Build-Depends:0': debhelper dependency version is too old (11). It should be 13
Offending value: 'debhelper (>= 11~)'
Warning in 'control source Build-Depends:0': debhelper dependency is deprecated. It should be a dependency for debhelper-compat package
Offending value: 'debhelper (>= 11~)'
Warning in 'control binary:"busybox-udeb" Section': Bad section. (this cannot be fixed with 'cme fix' command)
Offending value: 'debian-installer'
File debian/copyright line 1 has a syntax error:
	DpkgSyntax error: Invalid line (missing ':' ?) : This package was debianized by Erik Andersen <andersee@debian.org> on
Connecting to api.ftp-master.debian.org to check 3 package versions. Please wait...
Got info from api.ftp-master.debian.org for 3 packages.

Full worker log