Run of cme for cdebconf

Try this locally (using the lintian-brush package):

debcheckout cdebconf
cd cdebconf
cme-fix
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
[2021-05-22 01:36:11] Running ['cme-fix']
[2021-05-22 01:36:11] Opening branch at https://salsa.debian.org/installer-team/cdebconf.git/,branch=master
[2021-05-22 01:36:12] Using cached branch https://janitor.debian.net/git/cdebconf/,branch=debian%2Flatest
[2021-05-22 01:36:16] Total 21604 (delta 69), reused 10 (delta 10), pack-reused 21503
[2021-05-22 01:36:16] 
[2021-05-22 01:36:31]  (189/784)
[2021-05-22 01:36:31] 84)
[2021-05-22 01:36:31] 84), done.
[2021-05-22 01:36:31] Total 529 (delta 344), reused 246 (delta 75), pack-reused 0
[2021-05-22 01:36:32] Workspace ready - starting.

Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done


Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree... Done


Reading state information... 0% 

Reading state information... 0%

Reading state information... Done

Warning in 'control source Standards-Version': Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '3.9.7' to '4.5.1'.

Offending value: '3.9.7'
Warning in 'control source Build-Depends:1': unnecessary greater-than versioned dependency: po-debconf (>= 0.5.0). Debian has oldoldstable -> 1.0.16+nmu3; oldstable -> 1.0.20; stable -> 1.0.21; testing -> 1.0.21+nmu1; unstable -> 1.0.21+nmu1;
Offending value: 'po-debconf (>= 0.5.0)'
Warning in 'control source Build-Depends:4': unnecessary greater-than versioned dependency: libtextwrap-dev (>= 0.1-5). Debian has oldoldstable -> 0.1-14; oldstable -> 0.1-14.1; unstable -> 0.1-14.2; stable -> 0.1-14.2; testing -> 0.1-14.2;
Offending value: 'libtextwrap-dev (>= 0.1-5)'
Warning in 'control source Build-Depends:5': unnecessary greater-than versioned dependency: libdebian-installer4-dev (>= 0.41). Debian has oldoldstable -> 0.99+deb8u1; oldstable -> 0.110; stable -> 0.119; unstable -> 0.121; testing -> 0.121;
Offending value: 'libdebian-installer4-dev (>= 0.41) | libdebian-installer-dev'
Warning in 'control source Build-Depends:5': package libdebian-installer-dev is unknown. Check for typos if not a virtual package.
Offending value: 'libdebian-installer4-dev (>= 0.41) | libdebian-installer-dev'
Warning in 'control source Build-Depends:7': unnecessary greater-than versioned dependency: libgtk2.0-dev (>= 2.24) <!pkg.cdebconf.nogtk>. Debian has oldoldstable -> 2.24.25-3+deb8u2; oldstable -> 2.24.31-2; stable -> 2.24.32-3; testing -> 2.24.33-1; unstable -> 2.24.33-2;
Offending value: 'libgtk2.0-dev (>= 2.24) <!pkg.cdebconf.nogtk>'
Warning in 'control source Build-Depends:8': unnecessary greater-than versioned dependency: libcairo2-dev (>= 1.8.10-3) <!pkg.cdebconf.nogtk>. Debian has oldoldstable -> 1.14.0-2.1+deb8u2; oldstable -> 1.14.8-1; stable -> 1.16.0-4+deb10u1; unstable -> 1.16.0-5; testing -> 1.16.0-5;
Offending value: 'libcairo2-dev (>= 1.8.10-3) <!pkg.cdebconf.nogtk>'
Warning in 'control source Build-Depends:9': unnecessary greater-than versioned dependency: libselinux1-dev (>= 2.3). Debian has oldoldstable -> 2.3-2; oldstable -> 2.6-3+b3; stable -> 2.8-1+b1; testing -> 3.1-3; unstable -> 3.1-3; experimental -> 3.2-1;
Offending value: 'libselinux1-dev (>= 2.3) [linux-any] | libselinux-dev [linux-any]'
Warning in 'control source Build-Depends:9': package libselinux-dev is unknown. Check for typos if not a virtual package.
Offending value: 'libselinux1-dev (>= 2.3) [linux-any] | libselinux-dev [linux-any]'
Warning in 'control binary:cdebconf Depends:3': unnecessary greater-than versioned dependency: dpkg (>= 1.15.4). Debian has oldoldstable -> 1.17.27; oldstable -> 1.18.25; stable -> 1.19.7; unstable -> 1.20.9; testing -> 1.20.9;
Offending value: 'dpkg (>= 1.15.4)'
Warning in 'control binary:"cdebconf-gtk" Replaces:0': unnecessary older-than versioned dependency: cdebconf (<< 0.144). Debian has oldoldstable -> 0.192; oldstable -> 0.227; stable -> 0.249; testing -> 0.257; buildd-unstable -> 0.258; unstable -> 0.258;
Offending value: 'cdebconf (<< 0.144)'
Configuration item 'control binary:"cdebconf-gtk" Build-Profiles' has a wrong value:
	value '<!pkg.cdebconf.nogtk>' does not match regexp <!?[a-z0-9]+(?:\s+!?[a-z0-9]+)*>(?:\s+<!?[a-z0-9]+(?:\s+!?[a-z0-9]+)*>)*
Connecting to api.ftp-master.debian.org to check 21 package versions. Please wait...
Got info from api.ftp-master.debian.org for 12 packages.
Connecting to api.ftp-master.debian.org to check libdebian-installer-dev versions. Please wait...
got no info for libdebian-installer-dev
Connecting to api.ftp-master.debian.org to check libselinux-dev versions. Please wait...
got no info for libselinux-dev

Full worker log