Run of lintian-fixes for commons-beanutils

Try this locally (using the lintian-brush package):

debcheckout commons-beanutils
cd commons-beanutils
lintian-brush --exclude=upstream-metadata-file

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index fcbeaac..5df99f3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+commons-beanutils (1.9.4-2) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Use secure URI in Homepage field.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 03 Jun 2020 06:30:01 -0000
+
 commons-beanutils (1.9.4-1) unstable; urgency=medium
 
   * New upstream release
@@ -142,7 +152,7 @@ commons-beanutils (1.8.0-1) experimental; urgency=low
   * Add a Build-Depends-Indep dependency on maven-repo-helper
   * Use mh_installpom and mh_installjar to install the POM and the jar to the
     Maven repository
-  * Add ${misc:Depends} to Depends to clear Lintian warnings  
+  * Add ${misc:Depends} to Depends to clear Lintian warnings
   * Remove the full text of the Apache license
 
   [Matthias Klose]
@@ -218,7 +228,7 @@ commons-beanutils (1.6.1-5) unstable; urgency=low
 
 commons-beanutils (1.6.1-4) unstable; urgency=low
 
-  * rebuild by jikes with -source 1.3 option. 
+  * rebuild by jikes with -source 1.3 option.
     This keeps backward compatibility.
 
  -- Takashi Okamoto <tora@debian.org>  Fri,  6 Aug 2004 23:58:14 +0900
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de394..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index fc1646f..71d8389 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders:
  Ludovic Claude <ludovic.claude@laposte.net>,
  Emmanuel Bourg <ebourg@apache.org>
 Build-Depends:
- debhelper (>= 11),
+ debhelper-compat (= 12),
  default-jdk,
  default-jdk-doc,
  junit4,
@@ -19,10 +19,10 @@ Build-Depends:
  libmaven-bundle-plugin-java,
  libmaven-javadoc-plugin-java,
  maven-debian-helper (>= 2.0.2~)
-Standards-Version: 4.4.0
+Standards-Version: 4.5.0
 Vcs-Git: https://salsa.debian.org/java-team/commons-beanutils.git
 Vcs-Browser: https://salsa.debian.org/java-team/commons-beanutils
-Homepage: http://commons.apache.org/beanutils/
+Homepage: https://commons.apache.org/beanutils/
 
 Package: libcommons-beanutils-java
 Architecture: all

Full worker log Full build log