Run of cme for console-setup

Try this locally (using the lintian-brush package):

debcheckout console-setup
cd console-setup
cme-fix
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
[2021-05-22 01:26:58] Running ['cme-fix']
[2021-05-22 01:26:58] Opening branch at https://salsa.debian.org/installer-team/console-setup.git/,branch=master
[2021-05-22 01:27:01] Cached branch URL https://janitor.debian.net/git/console-setup,branch=debian%2Flatest missing: Branch does not exist: Not a branch: "https://janitor.debian.net/git/console-setup/": location is a repository.
[2021-05-22 01:27:01] 4/1200)
[2021-05-22 01:27:01]   93% (442/475)
[2021-05-22 01:27:05] Total 14109 (delta 764), reused 1149 (delta 720), pack-reused 12909
[2021-05-22 01:27:11] Workspace ready - starting.

Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done


Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree... Done


Reading state information... 0% 

Reading state information... 0%

Reading state information... Done

Warning in 'control source Standards-Version': Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '3.9.1' to '4.5.1'.

Offending value: '3.9.1'
Warning in 'control source Build-Depends:1': compat parameter is deprecated. Please use debhelper-compat dependency. See debhelper(7) for details.
Offending value: 'debhelper (>= 9.20160709)'
Warning in 'control source Build-Depends:1': debhelper dependency version is too old (9.20160709). It should be 13
Offending value: 'debhelper (>= 9.20160709)'
Warning in 'control source Build-Depends:1': debhelper dependency is deprecated. It should be a dependency for debhelper-compat package
Offending value: 'debhelper (>= 9.20160709)'
Warning in 'control source Build-Depends-Indep:0': unnecessary greater-than versioned dependency: xkb-data (>= 1.6). Debian has oldoldstable -> 2.12-1; oldstable -> 2.19-1+deb9u1; stable -> 2.26-2; unstable -> 2.29-2; testing -> 2.29-2;
Offending value: 'xkb-data (>= 1.6)'
Warning in 'control binary:"keyboard-configuration" Pre-Depends:0': unnecessary greater-than versioned dependency: debconf (>= 1.5.34). Debian has oldoldstable -> 1.5.56+deb8u1; oldstable -> 1.5.61; stable -> 1.5.71; testing -> 1.5.75; unstable -> 1.5.76;
Offending value: 'debconf (>= 1.5.34)'
Warning in 'control binary:"keyboard-configuration" Breaks:0': unnecessary older-than versioned dependency: console-setup (<< 1.71). Debian has oldoldstable -> 1.123; oldstable -> 1.164; stable -> 1.193~deb10u1; unstable -> 1.202; testing -> 1.202;
Offending value: 'console-setup (<< 1.71)'
Warning in 'control binary:"keyboard-configuration" Breaks:1': unnecessary older-than versioned dependency: console-setup-mini (<< 1.47). Debian has oldoldstable -> 1.123; oldstable -> 1.164; stable -> 1.193~deb10u1; unstable -> 1.202; testing -> 1.202;
Offending value: 'console-setup-mini (<< 1.47)'
Warning in 'control binary:"keyboard-configuration" Replaces:0': unnecessary older-than versioned dependency: console-setup (<< 1.47). Debian has oldoldstable -> 1.123; oldstable -> 1.164; stable -> 1.193~deb10u1; unstable -> 1.202; testing -> 1.202;
Offending value: 'console-setup (<< 1.47)'
Warning in 'control binary:"keyboard-configuration" Replaces:1': unnecessary older-than versioned dependency: console-setup-mini (<< 1.47). Debian has oldoldstable -> 1.123; oldstable -> 1.164; stable -> 1.193~deb10u1; unstable -> 1.202; testing -> 1.202;
Offending value: 'console-setup-mini (<< 1.47)'
Warning in 'control binary:"console-setup" Depends:0': package hurd is unknown. Check for typos if not a virtual package.
Offending value: 'console-setup-linux | console-setup-freebsd | hurd'
Warning in 'control binary:"console-setup" Depends:1': unnecessary greater-than versioned dependency: xkb-data (>= 0.9). Debian has oldoldstable -> 2.12-1; oldstable -> 2.19-1+deb9u1; stable -> 2.26-2; unstable -> 2.29-2; testing -> 2.29-2;
Offending value: 'xkb-data (>= 0.9)'
Warning in 'control binary:"console-setup" Suggests:0': unnecessary greater-than versioned dependency: lsb-base (>= 3.0-6). Debian has oldoldstable -> 4.1+Debian13+nmu1; oldstable -> 9.20161125; stable -> 10.2019051400; unstable -> 11.1.0; testing -> 11.1.0;
Offending value: 'lsb-base (>= 3.0-6)'
Warning in 'control binary:"console-setup" Pre-Depends:0': unnecessary greater-than versioned dependency: debconf (>= 1.5.34). Debian has oldoldstable -> 1.5.56+deb8u1; oldstable -> 1.5.61; stable -> 1.5.71; testing -> 1.5.75; unstable -> 1.5.76;
Offending value: 'debconf (>= 1.5.34)'
Warning in 'control binary:"console-setup" Breaks:0': unnecessary older-than versioned dependency: lsb-core (<< 2.0-6). Debian has oldoldstable -> 4.1+Debian13+nmu1;
Offending value: 'lsb-core (<< 2.0-6)'
Warning in 'control binary:"console-setup" Breaks:1': unnecessary older-than versioned dependency: lsb (<< 2.0-6). Debian has oldoldstable -> 4.1+Debian13+nmu1;
Offending value: 'lsb (<< 2.0-6)'
Warning in 'control binary:"console-setup" Breaks:2': unnecessary older-than versioned dependency: lsb-base (<< 3.0-6). Debian has oldoldstable -> 4.1+Debian13+nmu1; oldstable -> 9.20161125; stable -> 10.2019051400; unstable -> 11.1.0; testing -> 11.1.0;
Offending value: 'lsb-base (<< 3.0-6)'
Warning in 'control binary:"console-setup-mini" Depends:1': unnecessary greater-than versioned dependency: debconf (>= 0.5). Debian has oldoldstable -> 1.5.56+deb8u1; oldstable -> 1.5.61; stable -> 1.5.71; testing -> 1.5.75; unstable -> 1.5.76;
Offending value: 'debconf (>= 0.5) | debconf-2.0'
Warning in 'control binary:"console-setup-mini" Recommends:0': package console-tools is unknown. Check for typos if not a virtual package.
Offending value: 'kbd | console-tools'
Warning in 'control binary:"console-setup-mini" Suggests:0': unnecessary greater-than versioned dependency: lsb-base (>= 3.0-6). Debian has oldoldstable -> 4.1+Debian13+nmu1; oldstable -> 9.20161125; stable -> 10.2019051400; unstable -> 11.1.0; testing -> 11.1.0;
Offending value: 'lsb-base (>= 3.0-6)'
Warning in 'control binary:"console-setup-mini" Breaks:0': unnecessary older-than versioned dependency: lsb-core (<< 2.0-6). Debian has oldoldstable -> 4.1+Debian13+nmu1;
Offending value: 'lsb-core (<< 2.0-6)'
Warning in 'control binary:"console-setup-mini" Breaks:1': unnecessary older-than versioned dependency: lsb (<< 2.0-6). Debian has oldoldstable -> 4.1+Debian13+nmu1;
Offending value: 'lsb (<< 2.0-6)'
Warning in 'control binary:"console-setup-mini" Breaks:2': unnecessary older-than versioned dependency: lsb-base (<< 3.0-6). Debian has oldoldstable -> 4.1+Debian13+nmu1; oldstable -> 9.20161125; stable -> 10.2019051400; unstable -> 11.1.0; testing -> 11.1.0;
Offending value: 'lsb-base (<< 3.0-6)'
Warning in 'control binary:"console-setup-linux" Depends:0': unnecessary greater-than versioned dependency: kbd (>= 0.99-12). Debian has oldoldstable -> 1.15.5-2; oldstable -> 2.0.3-2+b1; stable -> 2.0.4-4; testing -> 2.3.0-3; unstable -> 2.3.0-3;
Offending value: 'kbd (>= 0.99-12) | console-tools (>= 1:0.2.3-16)'
Warning in 'control binary:"console-setup-linux" Depends:0': package console-tools is unknown. Check for typos if not a virtual package.
Offending value: 'kbd (>= 0.99-12) | console-tools (>= 1:0.2.3-16)'
Warning in 'control binary:"console-setup-linux" Breaks:0': package console-terminus is unknown. Check for typos if not a virtual package.
Offending value: 'console-terminus'
Warning in 'control binary:"console-setup-linux" Breaks:1': unnecessary older-than versioned dependency: console-cyrillic (<= 0.9-11). Debian has oldoldstable -> 0.9-16.2; stable -> 0.9-17; oldstable -> 0.9-17; unstable -> 0.9-17.1; testing -> 0.9-17.1;
Offending value: 'console-cyrillic (<= 0.9-11)'
Warning in 'control binary:"console-setup-linux" Breaks:2': unnecessary older-than versioned dependency: console-setup (<< 1.71). Debian has oldoldstable -> 1.123; oldstable -> 1.164; stable -> 1.193~deb10u1; unstable -> 1.202; testing -> 1.202;
Offending value: 'console-setup (<< 1.71)'
Warning in 'control binary:"console-setup-linux" Replaces:0': package console-terminus is unknown. Check for typos if not a virtual package.
Offending value: 'console-terminus'
Warning in 'control binary:"console-setup-linux" Replaces:1': unnecessary older-than versioned dependency: console-setup (<< 1.71). Debian has oldoldstable -> 1.123; oldstable -> 1.164; stable -> 1.193~deb10u1; unstable -> 1.202; testing -> 1.202;
Offending value: 'console-setup (<< 1.71)'
Warning in 'control binary:"console-setup-freebsd" Depends:0': package vidcontrol is unknown. Check for typos if not a virtual package.
Offending value: 'vidcontrol'
Warning in 'control binary:"console-setup-freebsd" Depends:1': package kbdcontrol is unknown. Check for typos if not a virtual package.
Offending value: 'kbdcontrol'
Warning in 'control binary:"console-setup-freebsd" Breaks:0': unnecessary older-than versioned dependency: console-setup (<< 1.71). Debian has oldoldstable -> 1.123; oldstable -> 1.164; stable -> 1.193~deb10u1; unstable -> 1.202; testing -> 1.202;
Offending value: 'console-setup (<< 1.71)'
Warning in 'control binary:"console-setup-freebsd" Replaces:0': unnecessary older-than versioned dependency: console-setup (<< 1.71). Debian has oldoldstable -> 1.123; oldstable -> 1.164; stable -> 1.193~deb10u1; unstable -> 1.202; testing -> 1.202;
Offending value: 'console-setup (<< 1.71)'
Warning in 'control binary:bdf2psf Depends:0': perl dependency better written as ${perl:Depends}
Offending value: 'perl'
Warning in 'control binary:"console-setup-udeb" Section': Bad section. (this cannot be fixed with 'cme fix' command)
Offending value: 'debian-installer'
Warning in 'control binary:"console-setup-udeb" Depends:0': package archdetect is unknown. Check for typos if not a virtual package.
Offending value: 'archdetect'
Warning in 'control binary:"console-setup-udeb" Depends:1': package cdebconf-udeb is unknown. Check for typos if not a virtual package.
Offending value: 'cdebconf-udeb'
Warning in 'control binary:"console-setup-udeb" Depends:2': package kbd-udeb is unknown. Check for typos if not a virtual package.
Offending value: 'kbd-udeb | kbdcontrol-udeb | hurd-udeb'
Warning in 'control binary:"console-setup-udeb" Depends:2': package kbdcontrol-udeb is unknown. Check for typos if not a virtual package.
Offending value: 'kbd-udeb | kbdcontrol-udeb | hurd-udeb'
Warning in 'control binary:"console-setup-udeb" Depends:2': package hurd-udeb is unknown. Check for typos if not a virtual package.
Offending value: 'kbd-udeb | kbdcontrol-udeb | hurd-udeb'
Warning in 'control binary:"console-setup-amiga-ekmap" Section': Bad section. (this cannot be fixed with 'cme fix' command)
Offending value: 'debian-installer'
Configuration item 'control binary:"console-setup-amiga-ekmap" Description' has a wrong value:
	Undefined mandatory value.
Connecting to api.ftp-master.debian.org to check 21 package versions. Please wait...
Got info from api.ftp-master.debian.org for 11 packages.
Connecting to api.ftp-master.debian.org to check hurd versions. Please wait...
got no info for hurd
Connecting to api.ftp-master.debian.org to check console-tools versions. Please wait...
got no info for console-tools
Connecting to api.ftp-master.debian.org to check console-terminus versions. Please wait...
got no info for console-terminus
Connecting to api.ftp-master.debian.org to check vidcontrol versions. Please wait...
got no info for vidcontrol
Connecting to api.ftp-master.debian.org to check kbdcontrol versions. Please wait...
got no info for kbdcontrol
Connecting to api.ftp-master.debian.org to check archdetect versions. Please wait...
got no info for archdetect
Connecting to api.ftp-master.debian.org to check cdebconf-udeb versions. Please wait...
got no info for cdebconf-udeb
Connecting to api.ftp-master.debian.org to check kbd-udeb versions. Please wait...
got no info for kbd-udeb
Connecting to api.ftp-master.debian.org to check kbdcontrol-udeb versions. Please wait...
got no info for kbdcontrol-udeb
Connecting to api.ftp-master.debian.org to check hurd-udeb versions. Please wait...
got no info for hurd-udeb

Full worker log