Run of cme for debian-archive-keyring

Try this locally (using the cme package):

debcheckout debian-archive-keyring
cd debian-archive-keyring
cme-fix
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
[2021-05-15 17:25:42] Running ['cme-fix']
[2021-05-15 17:25:42] Opening branch at https://salsa.debian.org/release-team/debian-archive-keyring.git/,branch=master
[2021-05-15 17:25:43] Using cached branch https://janitor.debian.net/git/debian-archive-keyring/,branch=debian%2Flatest
[2021-05-15 17:25:44] Total 473 (delta 0), reused 0 (delta 0), pack-reused 471
[2021-05-15 17:25:46] 1/191)
[2021-05-15 17:25:46] 27% (30/111)
[2021-05-15 17:25:46] Total 140 (delta 53), reused 107 (delta 29), pack-reused 0
[2021-05-15 17:25:47] Workspace ready - starting.

Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done


Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree... Done


Reading state information... 0% 

Reading state information... 0%

Reading state information... Done

Warning in 'control source Standards-Version': Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.1.2' to '4.5.1'.

Offending value: '4.1.2'
Warning in 'control source Build-Depends:0': compat parameter is deprecated. Please use debhelper-compat dependency. See debhelper(7) for details.
Offending value: 'debhelper (>= 10)'
Warning in 'control source Build-Depends:0': debhelper dependency version is too old (10). It should be 13
Offending value: 'debhelper (>= 10)'
Warning in 'control source Build-Depends:0': debhelper dependency is deprecated. It should be a dependency for debhelper-compat package
Offending value: 'debhelper (>= 10)'
Warning in 'control binary:"debian-archive-keyring-udeb" Section': Bad section. (this cannot be fixed with 'cme fix' command)
Offending value: 'debian-installer'
Warning in 'control binary:"debian-archive-keyring-udeb" Recommends:0': package gpgv-udeb is unknown. Check for typos if not a virtual package.
Offending value: 'gpgv-udeb'
File debian/copyright line 1 has a syntax error:
	DpkgSyntax error: Invalid line (missing ':' ?) : This is Debian GNU's GnuPG keyrings of archive keys.
Connecting to api.ftp-master.debian.org to check 4 package versions. Please wait...
Got info from api.ftp-master.debian.org for 3 packages.
Connecting to api.ftp-master.debian.org to check gpgv-udeb versions. Please wait...
got no info for gpgv-udeb

Full worker log