Run of fresh-snapshots for deutex

Try this locally (using silver-platter):

debian-svp new-upstream --snapshot deutex 

Merge these changes:

git pull https://janitor.debian.net/git/deutex fresh-snapshots/main

Summary

Merged new upstream version: 5.2.1+git20190811.fea5346 (was: 5.2.1).

Diff

diff --git a/configure.ac b/configure.ac
index c13b4a0..b4e085d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,13 @@ AM_SILENT_RULES([yes])
 AC_CHECK_PROG([ASCIIDOC], [a2x], [yes])
 AC_ARG_ENABLE([man],
     AS_HELP_STRING([--disable-man],
-                   [Disable manpage generation])
+                   [Disable manpage generation]),
+    [], [enable_man=check]
+)
+AS_IF([test "x$enable_man" = "xyes"],
+    AS_IF([test "x$ASCIIDOC" != "xyes"],
+        AC_MSG_ERROR([AsciiDoc a2x program is required in order to build the manual])
+    )
 )
 AM_CONDITIONAL([ASCIIDOC], [test "x$enable_man" != "xno" && test "x$ASCIIDOC" = "xyes"])
 
diff --git a/debian/changelog b/debian/changelog
index 17f8672..b0e25d7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+deutex (5.2.1+git20190811.fea5346-1) UNRELEASED; urgency=medium
+
+  * New upstream snapshot.
+  * Drop patch 0001-Check-for-manpage-generation-support-by-
+    default.patch, present upstream.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 17 Oct 2019 03:25:38 +0000
+
 deutex (5.2.1-1) unstable; urgency=medium
 
   * New upstream version 5.2.1
diff --git a/debian/patches/0001-Check-for-manpage-generation-support-by-default.patch b/debian/patches/0001-Check-for-manpage-generation-support-by-default.patch
deleted file mode 100644
index 77469d9..0000000
--- a/debian/patches/0001-Check-for-manpage-generation-support-by-default.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From fea53465b745657751b93c9b931088829d9b68bc Mon Sep 17 00:00:00 2001
-From: William Breathitt Gray <vilhelm.gray@gmail.com>
-Date: Sat, 10 Aug 2019 20:47:44 +0900
-Subject: [PATCH] Check for manpage generation support by default
-
-Searches for a2x by default, by only errors if --enable-man is
-explicitly given. This fixes Github issue #64.
----
- configure.ac | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index c13b4a0..b4e085d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -9,7 +9,13 @@ AM_SILENT_RULES([yes])
- AC_CHECK_PROG([ASCIIDOC], [a2x], [yes])
- AC_ARG_ENABLE([man],
-     AS_HELP_STRING([--disable-man],
--                   [Disable manpage generation])
-+                   [Disable manpage generation]),
-+    [], [enable_man=check]
-+)
-+AS_IF([test "x$enable_man" = "xyes"],
-+    AS_IF([test "x$ASCIIDOC" != "xyes"],
-+        AC_MSG_ERROR([AsciiDoc a2x program is required in order to build the manual])
-+    )
- )
- AM_CONDITIONAL([ASCIIDOC], [test "x$enable_man" != "xno" && test "x$ASCIIDOC" = "xyes"])
- 
--- 
-2.23.0.rc1
-
diff --git a/debian/patches/series b/debian/patches/series
index 01287c2..e69de29 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +0,0 @@
-0001-Check-for-manpage-generation-support-by-default.patch

Full worker log Full build log