Run of fresh-releases for eclipselink-jpa-2.1-spec

Try this locally (using silver-platter):

debian-svp new-upstream eclipselink-jpa-2.1-spec 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
Running ['new-upstream']
Opening branch at https://salsa.debian.org/java-team/eclipselink-jpa-2.1-spec.git/,branch=master
Using cached branch https://janitor.debian.net/git/eclipselink-jpa-2.1-spec/,branch=master
Total 314 (delta 0), reused 0 (delta 0), pack-reused 314
Total 0 (delta 0), reused 0 (delta 0), pack-reused 0

Total 6 (delta 0), reused 0 (delta 0), pack-reused 6
Total 2 (delta 0), reused 2 (delta 0), pack-reused 0
Workspace ready - starting.
/srv/janitor/debian-janitor/python-debian/lib/debian/copyright.py:654: UserWarning: Fixing Format URL
  warnings.warn('Fixing Format URL')
http://www.eclipse.org/eclipselink/ is permanently redirected to http://www.eclipse.org/eclipselink/
http://www.eclipse.org/eclipselink/ is permanently redirected to http://www.eclipse.org/eclipselink/
http://www.eclipse.org/eclipselink/ is permanently redirected to http://www.eclipse.org/eclipselink/
http://www.eclipse.org/eclipselink/ is permanently redirected to http://www.eclipse.org/eclipselink/
http://www.eclipse.org/eclipselink/ is permanently redirected to http://www.eclipse.org/eclipselink/
http://www.eclipse.org/eclipselink/ is permanently redirected to http://www.eclipse.org/eclipselink/
http://www.eclipse.org/eclipselink/ is permanently redirected to http://www.eclipse.org/eclipselink/
http://www.eclipse.org/eclipselink/ is permanently redirected to http://www.eclipse.org/eclipselink/
Using upstream branch https://janitor.debian.net/git/eclipselink-jpa-2.1-spec/ (guessed)
Using version string 2.2.0-RC3.
No upstream upstream-revision format specified, trying tag:2.1.0.v201304241213
No upstream upstream-revision format specified, trying tag:eclipselink-jpa-2.1-spec-2.1.0.v201304241213
No upstream upstream-revision format specified, trying tag:v2.1.0.v201304241213
No upstream upstream-revision format specified, trying tag:v.2.1.0.v201304241213
Old upstream version '2.1.0.v201304241213' is not present in upstream branch <UpstreamBranchSource for 'https://janitor.debian.net/git/eclipselink-jpa-2.1-spec/'>. Unable to determine whether upstream history is normally included. Assuming no.
/srv/janitor/debian-janitor/python-debian/lib/debian/copyright.py:654: UserWarning: Fixing Format URL
  warnings.warn('Fixing Format URL')
Using uscan to look for the upstream tarball.
Imported eclipselink-jpa-2.1-spec_2.2.0-RC3.orig.tar.gz with pristine-tar.
Traceback (most recent call last):
  File "/srv/janitor/debian-janitor/silver-platter/silver_platter/debian/upstream.py", line 1181, in make_changes
    result = merge_upstream(
  File "/srv/janitor/debian-janitor/silver-platter/silver_platter/debian/upstream.py", line 904, in merge_upstream
    conflicts, imported_revids = do_merge(
  File "/srv/janitor/debian-janitor/breezy-debian/merge_upstream.py", line 214, in do_merge
    return db.merge_upstream(
  File "/srv/janitor/debian-janitor/breezy-debian/import_dsc.py", line 1346, in merge_upstream
    conflicts = self.tree.merge_from_branch(
  File "/srv/janitor/debian-janitor/breezy/breezy/workingtree.py", line 681, in merge_from_branch
    conflicts = merger.do_merge()
  File "/srv/janitor/debian-janitor/breezy/breezy/merge.py", line 661, in do_merge
    merge = self._do_merge_to()
  File "/srv/janitor/debian-janitor/breezy/breezy/merge.py", line 630, in _do_merge_to
    merge.do_merge()
  File "/srv/janitor/debian-janitor/breezy/breezy/merge.py", line 765, in do_merge
    self._compute_transform()
  File "/srv/janitor/debian-janitor/breezy/breezy/merge.py", line 815, in _compute_transform
    self._finish_computing_transform()
  File "/srv/janitor/debian-janitor/breezy/breezy/merge.py", line 823, in _finish_computing_transform
    fs_conflicts = transform.resolve_conflicts(
  File "/srv/janitor/debian-janitor/breezy/breezy/transform.py", line 901, in resolve_conflicts
    raise MalformedTransform(conflicts=conflicts)
breezy.transform.MalformedTransform: Tree transform is malformed [('unversioned executability', 'new-8')]

Full worker log