Run of lintian-fixes for ember

Try this locally (using the lintian-brush package):

debcheckout ember
cd ember
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/ember lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 9451772..64a0a9b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+ember (0.8.0~snap3) UNRELEASED; urgency=low
+
+  * Use correct machine-readable copyright file URI.
+  * Move transitional package ember to oldlibs/optional per policy 4.0.1.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 24 Aug 2020 23:48:19 -0000
+
 ember (0.8.0~snap2) unstable; urgency=medium
 
   * Move to contrib since package now downloads external files
diff --git a/debian/control b/debian/control
index 155c852..bdcd665 100644
--- a/debian/control
+++ b/debian/control
@@ -15,6 +15,7 @@ Architecture: amd64
 Pre-Depends: snapd
 Depends: ${misc:Depends},
          ${shlibs:Depends}
+Section: oldlibs
 Description: 3D client framework for the WorldForge project
  Ember is a 3D client framework for WorldForge. It's not meant to be a
  standalone game, instead its purpose is to provide a solid and extensible
diff --git a/debian/copyright b/debian/copyright
index e738a43..ffeda81 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
 Source: https://github.com/worldforge/ember
 Comment: This package currently downloads the upstream snap package on install.
  This is due to the current instability of the upstream codebase. Once upstream

Debdiff

File lists identical (after any substitutions)

Control files: lines which differ (wdiff format)

  • Section: contrib/oldlibs oldlibs

Full worker log Full build log