Run of scrub-obsolete for fcitx-qt5

Try this locally (using the lintian-brush package):

debcheckout fcitx-qt5
cd fcitx-qt5
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/fcitx-qt5 scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 055b6ad..9c6e5df 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+fcitx-qt5 (1.2.5-2~exp2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake and extra-cmake-modules.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 20 May 2021 23:48:44 -0000
+
 fcitx-qt5 (1.2.5-2~exp1) experimental; urgency=medium
 
   * Team upload.
diff --git a/debian/control b/debian/control
index 663ccdd..88e23be 100644
--- a/debian/control
+++ b/debian/control
@@ -6,14 +6,14 @@ Uploaders:
  Aron Xu <aron@debian.org>,
  YunQiang Su <syq@debian.org>,
 Build-Depends:
- cmake (>= 3.1),
+ cmake,
  debhelper-compat (= 13),
- extra-cmake-modules (>= 1.4.0),
+ extra-cmake-modules,
  fcitx-libs-dev (>= 1:4.2.8),
  intltool,
  pkg-config,
  qtbase5-dev,
- qtbase5-private-dev,
+ qtbase5-private-dev
 Standards-Version: 4.5.1
 Homepage: https://www.fcitx-im.org
 Vcs-Git: https://salsa.debian.org/input-method-team/fcitx-qt5.git

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t unstable fcitx-frontend-qt5-dbgsym
apt install -t unstable fcitx-frontend-qt5
apt install -t unstable fcitx-module-quickphrase-editor-dbgsym
apt install -t unstable fcitx-module-quickphrase-editor
apt install -t unstable libfcitx-qt5-1-dbgsym
apt install -t unstable libfcitx-qt5-1
apt install -t unstable libfcitx-qt5-data
apt install -t unstable libfcitx-qt5-dev

Lintian Result

Full worker log Full build log