Run of scrub-obsolete for fcitx-rime

Try this locally (using the lintian-brush package):

debcheckout fcitx-rime
cd fcitx-rime
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/fcitx-rime scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index b503b2f..61868f2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+fcitx-rime (0.3.2-9) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + fcitx-rime: Drop versioned constraint on fcitx in Recommends.
+    + fcitx-rime: Drop versioned constraint on fcitx in Breaks.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 30 Dec 2020 20:13:09 -0000
+
 fcitx-rime (0.3.2-8) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/control b/debian/control
index 9ebb41d..9716f6b 100644
--- a/debian/control
+++ b/debian/control
@@ -33,9 +33,9 @@ Depends:
  ${misc:Depends},
  ${shlibs:Depends},
 Recommends:
- fcitx (>= 1:4.2.8.1),
+ fcitx,
 Breaks:
- fcitx (<< 1:4.2.0),
+ ,
 Description: Fcitx wrapper for RIME engine
  fcitx-rime is a wrapper of RIME engine for Fcitx.
  .

Full worker log Full build log