Run of lintian-fixes for geophar

Try this locally (using the lintian-brush package):

debcheckout geophar
cd geophar
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/geophar lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 2545767..7ff9d11 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+geophar (18.08.6+dfsg1-3) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Use secure copyright file specification URI.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+    Repository-Browse.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 11 Jul 2020 16:27:11 -0000
+
 geophar (18.08.6+dfsg1-2) unstable; urgency=medium
 
   * upgraded X-Python3-Version: 3.8. Closes: #956673
@@ -107,7 +119,7 @@ geophar (16.08.4~dfsg1-1) unstable; urgency=medium
 
   * New upstream release
   * Upgraded Standards-Version: 3.9.8
-  
+
  -- Georges Khaznadar <georgesk@debian.org>  Sun, 13 Nov 2016 22:12:28 +0100
 
 geophar (16.01~dfsg1-3) unstable; urgency=medium
@@ -177,6 +189,6 @@ geophar (14.07~dfsg1-1) unstable; urgency=low
         an access to Internet, dbus, and an X11 server.
   * customized two files to comply with Debian, see the patch.
   * added the command-line program geophar and a desktop file
-  * 
+  *
 
  -- Georges Khaznadar <georgesk@debian.org>  Sun, 23 Mar 2014 18:59:35 +0100
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de394..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index 0f1b98c..ca2ba0c 100644
--- a/debian/control
+++ b/debian/control
@@ -2,11 +2,11 @@ Source: geophar
 Section: math
 Priority: optional
 Maintainer: Georges Khaznadar <georgesk@debian.org>
-Build-Depends: debhelper (>= 11.0.0), python3-all, dh-python, quilt,
+Build-Depends: debhelper-compat (= 12), python3-all, dh-python, quilt,
  python3-sympy, python3-numpy, python3-matplotlib, python3-dbus,
  python3-sip, pyqt5-dev-tools,  qttools5-dev-tools, qt5-qmake,
  python3-scipy, python3-pyqt5.qsci, python3-pyqt5.qtsvg
-Standards-Version: 4.3.0
+Standards-Version: 4.5.0
 Homepage: http://sourceforge.net/projects/geophar/
 X-Python3-Version: 3.8
 Vcs-Browser: https://salsa.debian.org/georgesk/geophar
@@ -35,4 +35,3 @@ Description: Swiss army knife for the math teacher
   - graphs
   - function plotting
   - histograms, etc.
-
diff --git a/debian/copyright b/debian/copyright
index 3d5a0a2..928308e 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
 Upstream-Name: geophar
 Source: https://github.com/wxgeo/geophar
 
diff --git a/debian/rules b/debian/rules
index 2963777..2c28bf8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,7 +27,7 @@ override_dh_install:
 	install -d $(PIXMAPDIR)
 	install -m 644 debian/geophar.png $(PIXMAPDIR)/geophar.png
 	#######################################################
-	# replace javascript libraries which were bundled in the 
+	# replace javascript libraries which were bundled in the
 	# upstream package by symlinks
 	#######################################################
 
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 0000000..eac1bda
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,5 @@
+---
+Bug-Database: https://github.com/wxgeo/geophar/issues
+Bug-Submit: https://github.com/wxgeo/geophar/issues/new
+Repository: https://github.com/wxgeo/geophar.git
+Repository-Browse: https://github.com/wxgeo/geophar

Debdiff

File lists identical (after any substitutions)

No differences were encountered in the control files

Full worker log Full build log