Run of fresh-snapshots for github-backup

Try this locally (using silver-platter):

debian-svp new-upstream --snapshot github-backup 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
Opening branch at https://salsa.debian.org/debian/github-backup.git
Cached branch URL file:/home/janitor/vcs/git/github-backup,branch=master missing: Branch does not exist: Not a branch: "/home/janitor/vcs/git/github-backup/".
Total 1819 (delta 1211), reused 1577 (delta 1055), pack-reused 0

Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
Using upstream branch git://github-backup.branchable.com/ (guessed)
Total 138 (delta 97), reused 63 (delta 38)
Using version string 1.20200721.
Looking for upstream github-backup/1.20200721 in upstream branch <breezy.memorybranch.MemoryBranch object at 0x7f1ef6531100>.

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libghc-github-dev : Depends: libghc-aeson-dev-1.4.2.0-fe1b8 but it is not installable
                     Depends: libghc-base-dev-4.12.0.0-a86a1 but it is not installable
                     Depends: libghc-base-compat-dev-0.10.5-6c968 but it is not installable
                     Depends: libghc-base16-bytestring-dev-0.1.1.6-f55af but it is not installable
                     Depends: libghc-binary-dev-0.8.6.0-5ca49 but it is not installable
                     Depends: libghc-binary-orphans-dev-0.1.8.0-78d01 but it is not installable
                     Depends: libghc-byteable-dev-0.1.1-56c06 but it is not installable
                     Depends: libghc-bytestring-dev-0.10.8.2-20f27 but it is not installable
                     Depends: libghc-containers-dev-0.6.0.1-b7319 but it is not installable
                     Depends: libghc-cryptohash-dev-0.11.9-a5506 but it is not installable
                     Depends: libghc-deepseq-dev-1.4.4.0-b5530 but it is not installable
                     Depends: libghc-deepseq-generics-dev-0.2.0.0-7d03c but it is not installable
                     Depends: libghc-exceptions-dev-0.10.2-29311 but it is not installable
                     Depends: libghc-hashable-dev-1.2.7.0-4dcfe but it is not installable
                     Depends: libghc-http-client-dev-0.5.14-fdb6f but it is not installable
                     Depends: libghc-http-client-tls-dev-0.3.5.3-f682b but it is not installable
                     Depends: libghc-http-link-header-dev-1.0.3.1-f4d2b but it is not installable
                     Depends: libghc-http-types-dev-0.12.3-a4110 but it is not installable
                     Depends: libghc-iso8601-time-dev-0.1.5-3f3a4 but it is not installable
                     Depends: libghc-mtl-dev-2.2.2-07ff1 but it is not installable
                     Depends: libghc-network-uri-dev-2.6.1.0-2af69 but it is not installable
                     Depends: libghc-semigroups-dev-0.18.5-24910 but it is not installable
                     Depends: libghc-text-dev-1.2.3.1-538d8 but it is not installable
                     Depends: libghc-time-dev-1.8.0.2-76e12 but it is not installable
                     Depends: libghc-tls-dev-1.4.1-4ac66 but it is not installable
                     Depends: libghc-transformers-dev-0.5.6.2-08fea but it is not installable
                     Depends: libghc-transformers-compat-dev-0.6.5-0477a but it is not installable
                     Depends: libghc-unordered-containers-dev-0.2.10.0-31f27 but it is not installable
                     Depends: libghc-vector-dev-0.12.0.3-d7c01 but it is not installable
                     Depends: libghc-vector-instances-dev-3.4-3c5ca but it is not installable
E: Unable to correct problems, you have held broken packages.
Worker failed (dist-apt-broken-packages): Broken apt packages: Depends: libghc-vector-instances-dev-3.4-3c5ca but it is not installable
Elapsed time: 0:00:09.378359

Full worker log