Run of lintian-fixes for gitlab

Try this locally (using the lintian-brush package):

debcheckout gitlab
cd gitlab
lintian-brush
23716
23717
23718
23719
23720
23721
23722
23723
23724
23725
23726
23727
23728
23729
23730
23731
          Depends: ruby-task-list (>= 2.2~) but it is not going to be installed
          Depends: ruby-bootstrap-form (>= 4.2~) but it is not going to be installed
          Depends: ruby-rack (>= 2.0.7~) but 2.0.6-3 is to be installed
          Depends: ruby-httparty (>= 0.16.4~) but 0.16.2+dfsg1-3 is to be installed
          Depends: ruby-sshkey (>= 2.0~) but it is not going to be installed
 gitlab-common : Depends: gitlab-shell (>= 9.1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
spec                 FAIL badpkg
blame: arg:/home/janitor/tmp/tmpmqrv_qwy/build-area/gitlab-common_11.10.8+dfsg-2~jan+lint1_all.deb deb:gitlab-common arg:/home/janitor/tmp/tmpmqrv_qwy/build-area/gitlab_11.10.8+dfsg-2~jan+lint1_all.deb deb:gitlab /home/janitor/tmp/tmpmqrv_qwy/build-area/gitlab_11.10.8+dfsg-2~jan+lint1.dsc
badpkg: Test dependencies are unsatisfiable. A common reason is that your testbed is out of date with respect to the archive, and you need to use a current testbed or run apt-get update or use -U.
autopkgtest [03:37:32]: @@@@@@@@@@@@@@@@@@@@ summary
spec                 FAIL badpkg
blame: arg:/home/janitor/tmp/tmpmqrv_qwy/build-area/gitlab-common_11.10.8+dfsg-2~jan+lint1_all.deb deb:gitlab-common arg:/home/janitor/tmp/tmpmqrv_qwy/build-area/gitlab_11.10.8+dfsg-2~jan+lint1_all.deb deb:gitlab /home/janitor/tmp/tmpmqrv_qwy/build-area/gitlab_11.10.8+dfsg-2~jan+lint1.dsc
badpkg: Test dependencies are unsatisfiable. A common reason is that your testbed is out of date with respect to the archive, and you need to use a current testbed or run apt-get update or use -U.

E: Autopkgtest run failed.

Summary

Full build log Full worker log