Run of scrub-obsolete for gnome-twitch

Try this locally (using the package):

debcheckout gnome-twitch
cd gnome-twitch
DEB_UPDATE_CHANGELOG=auto scrub-obsolete

Diff

diff --git a/debian/control b/debian/control
index bf6a700..cb2491d 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: gnome-twitch
 Section: video
 Priority: optional
 Maintainer: Tim Dengel <tim.dengel.debian@gmail.com>
-Build-Depends: debhelper (>= 11), meson (>= 0.37.0), libgtk-3-dev (>= 3.20), libpeas-dev, libsoup2.4-dev, libjson-glib-dev, libgstreamer1.0-dev, libclutter-gst-3.0-dev, libclutter-gtk-1.0-dev, libwebkit2gtk-4.0-dev, libmpv-dev
+Build-Depends: debhelper, meson, libgtk-3-dev (>= 3.20), libpeas-dev, libsoup2.4-dev, libjson-glib-dev, libgstreamer1.0-dev, libclutter-gst-3.0-dev, libclutter-gtk-1.0-dev, libwebkit2gtk-4.0-dev, libmpv-dev
 Standards-Version: 4.1.4.1
 Homepage: https://github.com/vinszent/gnome-twitch
 Vcs-Git: https://github.com/dengelt/gnome-twitch.git -b debian/sid

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/lib/debug/.build-id/54/475b1327efcd069534d5490c432c9d2861dc2d.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/6a/ee00e0e2bf7904e232a82b4d4a9cd96a2603eb.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/8a/d9a3eb0ace150af2b44de1f41250313345cf28.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/8e/3f6958be67fafd60ada61c7f52b7c01018d414.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/98/d8693899591063d86e98755896c68d346cd3df.debug

Files in first set of .debs but not in second

-rw-r--r--  root/root   /usr/lib/debug/.build-id/18/a8112ea6a5d61ace721d48b71ea096b9788636.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/2d/e772ea0f5d193c14279d24bbb11ba39d5e35c4.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/a2/4ceb5cc22bf6db7422bb4427bc307ca1f2419a.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/eb/17205456a4922f755169afc56c4bb046460e33.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/fb/cb5005c8294aea16ea51989d09cdf3faa8a2ad.debug

Control files of package gnome-twitch: lines which differ (wdiff format)

  • Depends: libc6 (>= 2.7), libgdk-pixbuf2.0-0 libgdk-pixbuf-2.0-0 (>= 2.25.2), libglib2.0-0 (>= 2.43.2), libgtk-3-0 (>= 3.21.4), libjson-glib-1.0-0 (>= 1.2.0), 1.5.2), libpeas-1.0-0 (>= 1.0.0), libsoup2.4-1 (>= 2.41.90), libwebkit2gtk-4.0-37 (>= 2.15.1), libx11-6, dconf-gsettings-backend | gsettings-backend

Control files of package gnome-twitch-dbgsym: lines which differ (wdiff format)

  • Build-Ids: fbcb5005c8294aea16ea51989d09cdf3faa8a2ad 8e3f6958be67fafd60ada61c7f52b7c01018d414

No differences were encountered between the control files of package gnome-twitch-player-backend-gstreamer-cairo

Control files of package gnome-twitch-player-backend-gstreamer-cairo-dbgsym: lines which differ (wdiff format)

  • Build-Ids: eb17205456a4922f755169afc56c4bb046460e33 8ad9a3eb0ace150af2b44de1f41250313345cf28

No differences were encountered between the control files of package gnome-twitch-player-backend-gstreamer-clutter

Control files of package gnome-twitch-player-backend-gstreamer-clutter-dbgsym: lines which differ (wdiff format)

  • Build-Ids: 2de772ea0f5d193c14279d24bbb11ba39d5e35c4 98d8693899591063d86e98755896c68d346cd3df

No differences were encountered between the control files of package gnome-twitch-player-backend-gstreamer-opengl

Control files of package gnome-twitch-player-backend-gstreamer-opengl-dbgsym: lines which differ (wdiff format)

  • Build-Ids: a24ceb5cc22bf6db7422bb4427bc307ca1f2419a 54475b1327efcd069534d5490c432c9d2861dc2d

No differences were encountered between the control files of package gnome-twitch-player-backend-mpv-opengl

Control files of package gnome-twitch-player-backend-mpv-opengl-dbgsym: lines which differ (wdiff format)

  • Build-Ids: 18a8112ea6a5d61ace721d48b71ea096b9788636 6aee00e0e2bf7904e232a82b4d4a9cd96a2603eb

Publish History

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t scrub-obsolete gnome-twitch-dbgsym
apt install -t scrub-obsolete gnome-twitch-player-backend-gstreamer-cairo-dbgsym
apt install -t scrub-obsolete gnome-twitch-player-backend-gstreamer-cairo
apt install -t scrub-obsolete gnome-twitch-player-backend-gstreamer-clutter-dbgsym
apt install -t scrub-obsolete gnome-twitch-player-backend-gstreamer-clutter
apt install -t scrub-obsolete gnome-twitch-player-backend-gstreamer-opengl-dbgsym
apt install -t scrub-obsolete gnome-twitch-player-backend-gstreamer-opengl
apt install -t scrub-obsolete gnome-twitch-player-backend-mpv-opengl-dbgsym
apt install -t scrub-obsolete gnome-twitch-player-backend-mpv-opengl
apt install -t scrub-obsolete gnome-twitch

Lintian Result

Full worker log Full build log