Run of fresh-snapshots for gnome-user-docs

Try this locally package):


git clone  gnome-user-docs
cd gnome-user-docs
ogni dist

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
[2022-05-02 02:19:43] Opening branch at https://salsa.debian.org/gnome-team/gnome-user-docs.git/,branch=debian%2Fmaster
[2022-05-02 02:19:45] Using cached branch https://janitor.debian.net/git/gnome-user-docs/,branch=debian%2Flatest
[2022-05-02 02:19:45] Using resume branch: https://janitor.debian.net/git/gnome-user-docs,branch=fresh-snapshots%2Fmain
[2022-05-02 02:20:46] Total 91910 (delta 14774), reused 4769 (delta 0), pack-reused 72363
[2022-05-02 02:24:42] Total 69 (delta 3), reused 69 (delta 3), pack-reused 0
[2022-05-02 02:24:42] 
[2022-05-02 02:24:46] 2/1531)
[2022-05-02 02:24:47] Total 1531 (delta 28), reused 1503 (delta 0), pack-reused 0
[2022-05-02 02:24:47] 
[2022-05-02 02:50:40] All changes applied successfully.
[2022-05-02 02:50:41] Total 4 (delta 3), reused 1 (delta 0), pack-reused 0
[2022-05-02 02:50:46] restarting branch
[2022-05-02 02:50:47]  done.
[2022-05-02 02:50:47] Total 4 (delta 3), reused 1 (delta 0), pack-reused 0
[2022-05-02 02:50:53] ubuntu/40.4-1ubuntu1 does not point to a valid object
[2022-05-02 02:50:53] ubuntu/40.5-1ubuntu1 does not point to a valid object
[2022-05-02 02:50:53] ubuntu/41.0-1ubuntu1 does not point to a valid object
[2022-05-02 02:50:53] ubuntu/41.1-1ubuntu1 does not point to a valid object
[2022-05-02 02:50:53] ubuntu/41.2-1ubuntu1 does not point to a valid object
[2022-05-02 02:50:53] ubuntu/41.5-1ubuntu1 does not point to a valid object
[2022-05-02 02:50:53] ubuntu/41.5-1ubuntu2 does not point to a valid object
[2022-05-02 02:50:53] ubuntu/42.0-1ubuntu1 does not point to a valid object
[2022-05-02 03:16:34] All changes applied successfully.
[2022-05-02 03:16:35] Total 36 (delta 9), reused 35 (delta 8), pack-reused 0
[2022-05-02 03:16:37] ubuntu/40.4-1ubuntu1 does not point to a valid object
[2022-05-02 03:16:37] ubuntu/40.5-1ubuntu1 does not point to a valid object
[2022-05-02 03:16:37] ubuntu/41.0-1ubuntu1 does not point to a valid object
[2022-05-02 03:16:37] ubuntu/41.1-1ubuntu1 does not point to a valid object
[2022-05-02 03:16:37] ubuntu/41.2-1ubuntu1 does not point to a valid object
[2022-05-02 03:16:37] ubuntu/41.5-1ubuntu1 does not point to a valid object
[2022-05-02 03:16:37] ubuntu/41.5-1ubuntu2 does not point to a valid object
[2022-05-02 03:16:37] ubuntu/42.0-1ubuntu1 does not point to a valid object
[2022-05-02 03:16:37] Workspace ready - starting.
[2022-05-02 03:16:39] Running ['deb-new-upstream', '--snapshot', '--refresh-patches']
Using upstream branch https://gitlab.gnome.org/GNOME/gnome-user-docs.git (from configuration)
(59/92)
Total 204 (delta 114), reused 186 (delta 100), pack-reused 0

Using version string 42.0+git20220426.1.8b46d54.
No upstream upstream-revision format specified, trying tag:42.0
Including upstream history, since previous upstream version (42.0) is present in packaging branch history.
Looking for upstream 42.0+git20220426.1.8b46d54 in upstream branch <RemoteGitBranch('https://gitlab.gnome.org/GNOME/gnome-user-docs.git/', 'master')>.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python39.zip:/usr/lib/python3.9:/usr/lib/python3.9/lib-dynload:/usr/local/lib/python3.9/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitor4t9apvsv/gnome-user-docs/debian
Opened schroot session unstable-amd64-sbuild-dbe6819e-31cd-4383-b349-56e98a7d3f7a (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n               dh-sequence-gnome', 'yelp-tools,\n                     pkg-config']
Ignoring error installing declared build dependencies (apt-file-fetch-failure): Apt file fetch error: 404  Not Found [IP: 146.75.94.132 80]
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, cran, octave-forge]
Running ['./autogen.sh']
Identified error: MissingCommand(command='autoreconf')
Attempting to use fixer upstream requirement fixer([apt, cpan, ctan, pypi, npm, go, hackage, cran, cran, octave-forge]) to address MissingCommand(command='autoreconf')
Loading apt contents information
apt: running ['apt', '-y', 'satisfy', 'autoconf']
Running ['make', 'dist']
Build failed with unidentified error:
Makefile:829: *** missing separator.  Stop.
dist-command-failed: Makefile:829: *** missing separator.  Stop.
Makefile:829: *** missing separator.  Stop.

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=leave deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far. not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer None
  • ☒ change set b1405c1f-4bc9-4802-96d1-650b6a371153 is working

Full worker log