Run of lintian-fixes for gnuplot-mode

Try this locally (using the lintian-brush package):

debcheckout gnuplot-mode
cd gnuplot-mode
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/gnuplot-mode lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index d32f4fe..8fb729d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,17 @@
+gnuplot-mode (1:0.7.0-2014-12-31-3) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Strip unusual field spacing from debian/control.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 07 Apr 2021 08:26:28 -0000
+
 gnuplot-mode (1:0.7.0-2014-12-31-2) unstable; urgency=medium
 
   [ Dima Kogan ]
   * Moved repository to the emacsen-team
-  
+
   [ Nicholas D Steeves ]
   * Drop emacs24 and emacs25 from Enhances
   * Install dot.el and dotemacs.el using the "examples" mechanism
@@ -238,5 +247,3 @@ gnuplot-mode (0.5k-1) unstable; urgency=low
   * Initial Release.
 
  -- Ryuichi Arafune <arafune@debian.org>  Tue, 28 Mar 2000 13:23:58 +0900
-
-
diff --git a/debian/control b/debian/control
index 31c2c95..ae23f8f 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Build-Depends: debhelper (>= 10),
 	       texlive-latex-base,
 	       texlive-latex-recommended,
 	       gnuplot
-Standards-Version: 4.3.0
+Standards-Version: 4.5.0
 Vcs-Git: https://salsa.debian.org/emacsen-team/gnuplot-mode.git
 Vcs-Browser: https://salsa.debian.org/emacsen-team/gnuplot-mode
 Homepage: https://github.com/emacsorphanage/gnuplot
@@ -18,7 +18,7 @@ Architecture: all
 Depends: ${misc:Depends}, ${elpa:Depends}, gnuplot-qt | gnuplot-x11 | gnuplot
 Recommends: emacs (>= 46.0), gnuplot-doc
 Enhances: emacs
-Breaks:   gnuplot-mode (<< 1:0.7.0-2014-12-31-1)
+Breaks: gnuplot-mode (<< 1:0.7.0-2014-12-31-1)
 Replaces: gnuplot-mode (<< 1:0.7.0-2014-12-31-1)
 Provides: gnuplot-mode
 Description: Gnuplot mode for Emacs
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 0000000..631a42f
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,3 @@
+---
+Bug-Database: https://github.com/emacsorphanage/gnuplot/issues
+Bug-Submit: https://github.com/emacsorphanage/gnuplot/issues/new

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package elpa-gnuplot-mode

No differences were encountered between the control files of package gnuplot-mode

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t lintian-fixes elpa-gnuplot-mode
apt install -t lintian-fixes gnuplot-mode

Lintian Result

Full worker log Full build log