Run of lintian-fixes for gulkan

Try this locally (using the lintian-brush package):

debcheckout gulkan
cd gulkan
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/gulkan lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 399e6f1..7b07d9d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+gulkan (0.15.1-3) UNRELEASED; urgency=low
+
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Repository, Repository-Browse.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Tue, 21 Jul 2020 23:19:12 -0000
+
 gulkan (0.15.1-2) unstable; urgency=medium
 
   * Source only upload.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de394..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index 9360b22..7c83198 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: gulkan
 Priority: optional
 Maintainer: Andrew Lee (李健秋) <ajqlee@debian.org>
 Uploaders: Héctor Orón Martínez <zumbi@debian.org>
-Build-Depends: debhelper (>= 11),
+Build-Depends: debhelper-compat (= 12),
                glslang-tools,
                gtk-doc-tools,
                libcairo2-dev,
@@ -13,7 +13,7 @@ Build-Depends: debhelper (>= 11),
                libgraphene-1.0-dev,
                libvulkan-dev,
                meson
-Standards-Version: 4.3.0
+Standards-Version: 4.5.0
 Section: libs
 Homepage: https://gitlab.freedesktop.org/xrdesktop/gulkan
 Vcs-Browser: https://salsa.debian.org/xrdesktop-team/gulkan
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 0000000..d28e406
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,3 @@
+---
+Repository: https://gitlab.freedesktop.org/xrdesktop/gulkan.git
+Repository-Browse: https://gitlab.freedesktop.org/xrdesktop/gulkan

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package libgulkan-0.15-0

No differences were encountered between the control files of package libgulkan-0.15-0-dbgsym

No differences were encountered between the control files of package libgulkan-dev

No differences were encountered between the control files of package libgulkan-doc

Control files of package libgulkan-utils: lines which differ (wdiff format)

  • Depends: libc6 (>= 2.4), libgdk-pixbuf2.0-0 (>= 2.25.2), libglfw3 (>= 3.2), libglib2.0-0 (>= 2.37.3), libgraphene-1.0-0 (>= 1.5.4), libgulkan-0.15-0, libgulkan-0.15-0 (>= 0.15.1), libvulkan1 (>= 1.2.131.2)

No differences were encountered between the control files of package libgulkan-utils-dbgsym

Full worker log Full build log