Run of cme for haskell-lambdabot-haskell-plugins

Try this locally (using the cme package):

debcheckout haskell-lambdabot-haskell-plugins
cd haskell-lambdabot-haskell-plugins
DEB_UPDATE_CHANGELOG=auto cme fix dpkg
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
[2021-06-16 08:20:17] Running ['cme', 'fix', 'dpkg']
[2021-06-16 08:20:17] Opening branch at https://salsa.debian.org/haskell-team/DHG_packages.git/,branch=master
[2021-06-16 08:20:19] Cached branch URL https://janitor.debian.net/git/haskell-lambdabot-haskell-plugins,branch=debian%2Flatest missing: Branch does not exist: Not a branch: "https://janitor.debian.net/git/haskell-lambdabot-haskell-plugins/": location is a repository.
[2021-06-16 08:20:21] (3331/4971)
[2021-06-16 08:20:23] Total 294874 (delta 2551), reused 4915 (delta 2508), pack-reused 289903
[2021-06-16 08:23:00] Workspace ready - starting.
[2021-06-16 08:23:02] assuming changelog needs to be updated since gbp dch only suppors a debian directory in the root of the repository
Warning in 'control source Standards-Version': Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.5.0' to '4.5.1'.

Offending value: '4.5.0'
Warning in 'control source Build-Depends:1': compat parameter is deprecated. Please use debhelper-compat dependency. See debhelper(7) for details.
Offending value: 'debhelper (>= 10)'
Warning in 'control source Build-Depends:1': debhelper dependency version is too old (10). It should be 13
Offending value: 'debhelper (>= 10)'
Warning in 'control source Build-Depends:1': debhelper dependency is deprecated. It should be a dependency for debhelper-compat package
Offending value: 'debhelper (>= 10)'
Warning in 'control source Build-Depends:5': unnecessary greater-than versioned dependency: libghc-arrows-dev (>= 0.4). Debian has oldoldstable -> 0.4.4.1-3+b2; oldstable -> 0.4.4.1-9+b1; stable -> 0.4.4.2-2+b2; stable -> 0.4.4.2-2+b3; unstable -> 0.4.4.2-3+b1; testing -> 0.4.4.2-3+b1; unstable -> 0.4.4.2-3+b2; testing -> 0.4.4.2-3+b2; unstable -> 0.4.4.2-3+b3; testing -> 0.4.4.2-3+b3;
Offending value: 'libghc-arrows-dev (>= 0.4)'
Warning in 'control source Build-Depends:7': unnecessary greater-than versioned dependency: libghc-data-memocombinators-dev (>= 0.4). Debian has oldoldstable -> 0.4.4-3; oldstable -> 0.5.1-6; stable -> 0.5.1-8+b2; stable -> 0.5.1-8+b3; testing -> 0.5.1-9+b1; unstable -> 0.5.1-9+b1; testing -> 0.5.1-9+b2; unstable -> 0.5.1-9+b2;
Offending value: 'libghc-data-memocombinators-dev (>= 0.4)'
Warning in 'control source Build-Depends:9': unnecessary greater-than versioned dependency: libghc-src-exts-simple-dev (>= 1.18). Debian has stable -> 1.20.0.0-2+b2; stable -> 1.20.0.0-2+b3; testing -> 1.23.0.0-1; unstable -> 1.23.0.0-1; testing -> 1.23.0.0-1+b1; unstable -> 1.23.0.0-1+b1;
Offending value: 'libghc-src-exts-simple-dev (>= 1.18)'
Warning in 'control source Build-Depends:14': unnecessary greater-than versioned dependency: libghc-iospec-dev (>= 0.2). Debian has oldoldstable -> 0.2.5-4+b2; oldoldstable -> 0.2.5-4+b3; oldstable -> 0.3-4+b1; stable -> 0.3-7+b2; stable -> 0.3-7+b3; unstable -> 0.3.1.1-2+b1; testing -> 0.3.1.1-2+b1; unstable -> 0.3.1.1-2+b2; testing -> 0.3.1.1-2+b2; unstable -> 0.3.1.1-2+b3; testing -> 0.3.1.1-2+b3;
Offending value: 'libghc-iospec-dev (>= 0.2)'
Warning in 'control source Build-Depends:25': unnecessary greater-than versioned dependency: libghc-lifted-base-dev (>= 0.2). Debian has oldoldstable -> 0.2.0.3-2+b1; oldstable -> 0.2.3.8-3; stable -> 0.2.3.12-2+b1; stable -> 0.2.3.12-2+b2; stable -> 0.2.3.12-2+b3; unstable -> 0.2.3.12-3+b1; testing -> 0.2.3.12-3+b1; unstable -> 0.2.3.12-3+b2; testing -> 0.2.3.12-3+b2;
Offending value: 'libghc-lifted-base-dev (>= 0.2)'
Warning in 'control source Build-Depends:27': unnecessary greater-than versioned dependency: libghc-logict-dev (>= 0.5). Debian has oldoldstable -> 0.6.0.2-1; oldstable -> 0.6.0.2-7; stable -> 0.6.0.2-10+b2; stable -> 0.6.0.2-10+b3; unstable -> 0.7.0.2-1+b1; testing -> 0.7.0.2-1+b1; unstable -> 0.7.0.2-1+b2; testing -> 0.7.0.2-1+b2;
Offending value: 'libghc-logict-dev (>= 0.5)'
Warning in 'control source Build-Depends:29': unnecessary greater-than versioned dependency: libghc-monadrandom-dev (>= 0.1). Debian has oldoldstable -> 0.1.13-1; oldstable -> 0.4.2.3-3+b1; stable -> 0.5.1.1-3+b2; stable -> 0.5.1.1-3+b3; unstable -> 0.5.2-1; testing -> 0.5.2-1;
Offending value: 'libghc-monadrandom-dev (>= 0.1)'
Warning in 'control source Build-Depends:36': unnecessary greater-than versioned dependency: libghc-numbers-dev (>= 3000). Debian has oldoldstable -> 3000.1.0.3-1; oldstable -> 3000.2.0.1-6; stable -> 3000.2.0.2-2+b2; stable -> 3000.2.0.2-2+b3; testing -> 3000.2.0.2-3+b1; unstable -> 3000.2.0.2-3+b1; testing -> 3000.2.0.2-3+b2; unstable -> 3000.2.0.2-3+b2;
Offending value: 'libghc-numbers-dev (>= 3000)'
Warning in 'control source Build-Depends:38': unnecessary greater-than versioned dependency: libghc-oeis-dev (>= 0.3.1). Debian has oldoldstable -> 0.3.1-5+b2; oldoldstable -> 0.3.1-5+b3; oldstable -> 0.3.7-3+b1; stable -> 0.3.9-3+b2; stable -> 0.3.9-3+b3; unstable -> 0.3.10-1+b1; testing -> 0.3.10-1+b1; unstable -> 0.3.10-1+b2; testing -> 0.3.10-1+b2;
Offending value: 'libghc-oeis-dev (>= 0.3.1)'
Warning in 'control source Build-Depends:40': unnecessary greater-than versioned dependency: libghc-quickcheck2-dev (>= 2). Debian has oldoldstable -> 2.7.6-3; oldstable -> 2.8.2-3+b1; stable -> 2.11.3-1+b2; stable -> 2.11.3-1+b3; testing -> 2.13.2-1+b1; unstable -> 2.13.2-1+b1; testing -> 2.13.2-1+b2; unstable -> 2.13.2-1+b2; testing -> 2.13.2-1+b3; unstable -> 2.13.2-1+b3;
Offending value: 'libghc-quickcheck2-dev (>= 2)'
Warning in 'control source Build-Depends:42': unnecessary greater-than versioned dependency: libghc-regex-tdfa-dev (>= 1.1). Debian has oldoldstable -> 1.2.0-1; oldstable -> 1.2.2-3+b1; stable -> 1.2.3.1-4+b2; stable -> 1.2.3.1-4+b3; unstable -> 1.3.1.0-2+b1; testing -> 1.3.1.0-2+b1; unstable -> 1.3.1.0-2+b2; testing -> 1.3.1.0-2+b2;
Offending value: 'libghc-regex-tdfa-dev (>= 1.1)'
Warning in 'control source Build-Depends:44': unnecessary greater-than versioned dependency: libghc-show-dev (>= 0.4). Debian has oldoldstable -> 0.6-1; oldstable -> 0.6-7; stable -> 0.6-9+b2; stable -> 0.6-9+b3; unstable -> 0.6-10+b1; testing -> 0.6-10+b1; unstable -> 0.6-10+b2; testing -> 0.6-10+b2;
Offending value: 'libghc-show-dev (>= 0.4)'
Warning in 'control source Build-Depends:46': unnecessary greater-than versioned dependency: libghc-split-dev (>= 0.2). Debian has oldoldstable -> 0.2.2-1; oldstable -> 0.2.3.1-3; stable -> 0.2.3.3-2+b2; stable -> 0.2.3.3-2+b3; testing -> 0.2.3.4-1+b1; unstable -> 0.2.3.4-1+b1; testing -> 0.2.3.4-1+b2; unstable -> 0.2.3.4-1+b2;
Offending value: 'libghc-split-dev (>= 0.2)'
Warning in 'control source Build-Depends:48': unnecessary greater-than versioned dependency: libghc-syb-dev (>= 0.3). Debian has oldoldstable -> 0.4.0-1; oldstable -> 0.6-3; stable -> 0.7-3+b2; stable -> 0.7-3+b3; unstable -> 0.7.1-2+b1; testing -> 0.7.1-2+b1; unstable -> 0.7.1-2+b2; testing -> 0.7.1-2+b2;
Offending value: 'libghc-syb-dev (>= 0.3)'
Warning in 'control source Build-Depends:52': unnecessary greater-than versioned dependency: libghc-utf8-string-dev (>= 0.3). Debian has oldoldstable -> 0.3.7-3; oldstable -> 1.0.1.1-4+b1; stable -> 1.0.1.1-8+b2; stable -> 1.0.1.1-8+b3; unstable -> 1.0.1.1-9+b1; testing -> 1.0.1.1-9+b1; unstable -> 1.0.1.1-9+b2; testing -> 1.0.1.1-9+b2;
Offending value: 'libghc-utf8-string-dev (>= 0.3)'
Warning in 'control source Build-Depends:54': unnecessary greater-than versioned dependency: libghc-vector-space-dev (>= 0.8). Debian has oldoldstable -> 0.8.6-3+b8; oldoldstable -> 0.8.6-3+b9; oldstable -> 0.10.4-3; stable -> 0.13-2+b2; stable -> 0.13-2+b3; unstable -> 0.16-1+b1; testing -> 0.16-1+b1; unstable -> 0.16-1+b2; testing -> 0.16-1+b2;
Offending value: 'libghc-vector-space-dev (>= 0.8)'
deleting debian/compat
[2021-06-16 08:23:23] Committing to: /srv/janitor/tmp/janitor675r8gs3/haskell-lambdabot-haskell-plugins/
[2021-06-16 08:23:24] modified p/haskell-lambdabot-haskell-plugins/debian/changelog
[2021-06-16 08:23:24] missing p/haskell-lambdabot-haskell-plugins/debian/compat
[2021-06-16 08:23:24] deleted p/haskell-lambdabot-haskell-plugins/debian/compat
[2021-06-16 08:23:24] modified p/haskell-lambdabot-haskell-plugins/debian/control
Traceback (most recent call last):
  File "/srv/janitor/debian-janitor/janitor/pull_worker.py", line 262, in run_worker
    with process_package(
  File "/usr/lib/python3.9/contextlib.py", line 117, in __enter__
    return next(self.gen)
  File "/srv/janitor/debian-janitor/janitor/worker.py", line 817, in process_package
    changer_result = build_target.make_changes(
  File "/srv/janitor/debian-janitor/janitor/worker.py", line 489, in make_changes
    return self.changer.make_changes(
  File "/srv/janitor/debian-janitor/janitor/worker.py", line 394, in make_changes
    command_result = debian_script_runner(
  File "/srv/janitor/debian-janitor/silver-platter/silver_platter/debian/apply.py", line 201, in script_runner
    new_revision = local_tree.commit(result.description, allow_pointless=False)
  File "/srv/janitor/debian-janitor/breezy/breezy/mutabletree.py", line 167, in commit
    committed_id = commit.Commit().commit(working_tree=self,
  File "/srv/janitor/debian-janitor/breezy/breezy/commit.py", line 425, in commit
    self.rev_id = self.builder.commit(self.message)
  File "/srv/janitor/debian-janitor/breezy/breezy/git/commit.py", line 181, in commit
    self._validate_unicode_text(message, 'commit message')
  File "/srv/janitor/debian-janitor/breezy/breezy/repository.py", line 146, in _validate_unicode_text
    raise ValueError('Invalid value for %s: %r' % (context, text))
ValueError: Invalid value for commit message: "\rReading package lists... 0%\r\rReading package lists... 100%\r\rReading package lists... Done\r\n\rBuilding dependency tree... 0%\r\rBuilding dependency tree... 0%\r\rBuilding dependency tree... 50%\r\rBuilding dependency tree... 50%\r\rBuilding dependency tree... Done\r\n\rReading state information... 0% \r\rReading state information... 0%\r\rReading state information... Done\r\nConnecting to api.ftp-master.debian.org to check 49 package versions. Please wait...\nGot info from api.ftp-master.debian.org for 49 packages.\n\nChanges applied to dpkg configuration:\n- control source Standards-Version: '4.5.0' -> '4.5.1' # applied fix for :Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.5.0' to '4.5.1'.\n\n- compat deleted value: '10'\n- control source Build-Depends:1: 'debhelper (>= 10)' -> 'debhelper-compat (= 13)' # applied fix for :Cleared deprecated compat value; Set debhelper dependency version to 13~; changed debhelper dependency to debhelper dependency\n- control source Build-Depends:5: 'libghc-arrows-dev (>= 0.4)' -> 'libghc-arrows-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-arrows-dev (>= 0.4). Debian has oldoldstable -> 0.4.4.1-3+b2; oldstable -> 0.4.4.1-9+b1; stable -> 0.4.4.2-2+b2; stable -> 0.4.4.2-2+b3; unstable -> 0.4.4.2-3+b1; testing -> 0.4.4.2-3+b1; unstable -> 0.4.4.2-3+b2; testing -> 0.4.4.2-3+b2; unstable -> 0.4.4.2-3+b3; testing -> 0.4.4.2-3+b3;\n- control source Build-Depends:7: 'libghc-data-memocombinators-dev (>= 0.4)' -> 'libghc-data-memocombinators-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-data-memocombinators-dev (>= 0.4). Debian has oldoldstable -> 0.4.4-3; oldstable -> 0.5.1-6; stable -> 0.5.1-8+b2; stable -> 0.5.1-8+b3; testing -> 0.5.1-9+b1; unstable -> 0.5.1-9+b1; testing -> 0.5.1-9+b2; unstable -> 0.5.1-9+b2;\n- control source Build-Depends:9: 'libghc-src-exts-simple-dev (>= 1.18)' -> 'libghc-src-exts-simple-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-src-exts-simple-dev (>= 1.18). Debian has stable -> 1.20.0.0-2+b2; stable -> 1.20.0.0-2+b3; testing -> 1.23.0.0-1; unstable -> 1.23.0.0-1; testing -> 1.23.0.0-1+b1; unstable -> 1.23.0.0-1+b1;\n- control source Build-Depends:14: 'libghc-iospec-dev (>= 0.2)' -> 'libghc-iospec-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-iospec-dev (>= 0.2). Debian has oldoldstable -> 0.2.5-4+b2; oldoldstable -> 0.2.5-4+b3; oldstable -> 0.3-4+b1; stable -> 0.3-7+b2; stable -> 0.3-7+b3; unstable -> 0.3.1.1-2+b1; testing -> 0.3.1.1-2+b1; unstable -> 0.3.1.1-2+b2; testing -> 0.3.1.1-2+b2; unstable -> 0.3.1.1-2+b3; testing -> 0.3.1.1-2+b3;\n- control source Build-Depends:25: 'libghc-lifted-base-dev (>= 0.2)' -> 'libghc-lifted-base-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-lifted-base-dev (>= 0.2). Debian has oldoldstable -> 0.2.0.3-2+b1; oldstable -> 0.2.3.8-3; stable -> 0.2.3.12-2+b1; stable -> 0.2.3.12-2+b2; stable -> 0.2.3.12-2+b3; unstable -> 0.2.3.12-3+b1; testing -> 0.2.3.12-3+b1; unstable -> 0.2.3.12-3+b2; testing -> 0.2.3.12-3+b2;\n- control source Build-Depends:27: 'libghc-logict-dev (>= 0.5)' -> 'libghc-logict-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-logict-dev (>= 0.5). Debian has oldoldstable -> 0.6.0.2-1; oldstable -> 0.6.0.2-7; stable -> 0.6.0.2-10+b2; stable -> 0.6.0.2-10+b3; unstable -> 0.7.0.2-1+b1; testing -> 0.7.0.2-1+b1; unstable -> 0.7.0.2-1+b2; testing -> 0.7.0.2-1+b2;\n- control source Build-Depends:29: 'libghc-monadrandom-dev (>= 0.1)' -> 'libghc-monadrandom-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-monadrandom-dev (>= 0.1). Debian has oldoldstable -> 0.1.13-1; oldstable -> 0.4.2.3-3+b1; stable -> 0.5.1.1-3+b2; stable -> 0.5.1.1-3+b3; unstable -> 0.5.2-1; testing -> 0.5.2-1;\n- control source Build-Depends:36: 'libghc-numbers-dev (>= 3000)' -> 'libghc-numbers-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-numbers-dev (>= 3000). Debian has oldoldstable -> 3000.1.0.3-1; oldstable -> 3000.2.0.1-6; stable -> 3000.2.0.2-2+b2; stable -> 3000.2.0.2-2+b3; testing -> 3000.2.0.2-3+b1; unstable -> 3000.2.0.2-3+b1; testing -> 3000.2.0.2-3+b2; unstable -> 3000.2.0.2-3+b2;\n- control source Build-Depends:38: 'libghc-oeis-dev (>= 0.3.1)' -> 'libghc-oeis-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-oeis-dev (>= 0.3.1). Debian has oldoldstable -> 0.3.1-5+b2; oldoldstable -> 0.3.1-5+b3; oldstable -> 0.3.7-3+b1; stable -> 0.3.9-3+b2; stable -> 0.3.9-3+b3; unstable -> 0.3.10-1+b1; testing -> 0.3.10-1+b1; unstable -> 0.3.10-1+b2; testing -> 0.3.10-1+b2;\n- control source Build-Depends:40: 'libghc-quickcheck2-dev (>= 2)' -> 'libghc-quickcheck2-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-quickcheck2-dev (>= 2). Debian has oldoldstable -> 2.7.6-3; oldstable -> 2.8.2-3+b1; stable -> 2.11.3-1+b2; stable -> 2.11.3-1+b3; testing -> 2.13.2-1+b1; unstable -> 2.13.2-1+b1; testing -> 2.13.2-1+b2; unstable -> 2.13.2-1+b2; testing -> 2.13.2-1+b3; unstable -> 2.13.2-1+b3;\n- control source Build-Depends:42: 'libghc-regex-tdfa-dev (>= 1.1)' -> 'libghc-regex-tdfa-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-regex-tdfa-dev (>= 1.1). Debian has oldoldstable -> 1.2.0-1; oldstable -> 1.2.2-3+b1; stable -> 1.2.3.1-4+b2; stable -> 1.2.3.1-4+b3; unstable -> 1.3.1.0-2+b1; testing -> 1.3.1.0-2+b1; unstable -> 1.3.1.0-2+b2; testing -> 1.3.1.0-2+b2;\n- control source Build-Depends:44: 'libghc-show-dev (>= 0.4)' -> 'libghc-show-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-show-dev (>= 0.4). Debian has oldoldstable -> 0.6-1; oldstable -> 0.6-7; stable -> 0.6-9+b2; stable -> 0.6-9+b3; unstable -> 0.6-10+b1; testing -> 0.6-10+b1; unstable -> 0.6-10+b2; testing -> 0.6-10+b2;\n- control source Build-Depends:46: 'libghc-split-dev (>= 0.2)' -> 'libghc-split-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-split-dev (>= 0.2). Debian has oldoldstable -> 0.2.2-1; oldstable -> 0.2.3.1-3; stable -> 0.2.3.3-2+b2; stable -> 0.2.3.3-2+b3; testing -> 0.2.3.4-1+b1; unstable -> 0.2.3.4-1+b1; testing -> 0.2.3.4-1+b2; unstable -> 0.2.3.4-1+b2;\n- control source Build-Depends:48: 'libghc-syb-dev (>= 0.3)' -> 'libghc-syb-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-syb-dev (>= 0.3). Debian has oldoldstable -> 0.4.0-1; oldstable -> 0.6-3; stable -> 0.7-3+b2; stable -> 0.7-3+b3; unstable -> 0.7.1-2+b1; testing -> 0.7.1-2+b1; unstable -> 0.7.1-2+b2; testing -> 0.7.1-2+b2;\n- control source Build-Depends:52: 'libghc-utf8-string-dev (>= 0.3)' -> 'libghc-utf8-string-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-utf8-string-dev (>= 0.3). Debian has oldoldstable -> 0.3.7-3; oldstable -> 1.0.1.1-4+b1; stable -> 1.0.1.1-8+b2; stable -> 1.0.1.1-8+b3; unstable -> 1.0.1.1-9+b1; testing -> 1.0.1.1-9+b1; unstable -> 1.0.1.1-9+b2; testing -> 1.0.1.1-9+b2;\n- control source Build-Depends:54: 'libghc-vector-space-dev (>= 0.8)' -> 'libghc-vector-space-dev' # applied fix for :unnecessary greater-than versioned dependency: libghc-vector-space-dev (>= 0.8). Debian has oldoldstable -> 0.8.6-3+b8; oldoldstable -> 0.8.6-3+b9; oldstable -> 0.10.4-3; stable -> 0.13-2+b2; stable -> 0.13-2+b3; unstable -> 0.16-1+b1; testing -> 0.16-1+b1; unstable -> 0.16-1+b2; testing -> 0.16-1+b2;\n\n"

Full worker log