Run of lintian-fixes for ibutils

Try this locally (using the lintian-brush package):

debcheckout ibutils
cd ibutils
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/ibutils lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 5ca8f7c..7a91e34 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+ibutils (1.5.7+0.2.gbd7e502-3) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Wrap long lines in changelog entries: 1.5.7-5.
+  * Bump debhelper from deprecated 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Drop unnecessary dependency on dh-autoreconf.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 25 Apr 2020 05:09:08 +0000
+
 ibutils (1.5.7+0.2.gbd7e502-2) unstable; urgency=medium
 
   * Fix FTBFS in buster/sid (ld: cannot find -libiscom) (Closes: #906553).
@@ -26,8 +36,10 @@ ibutils (1.5.7+0.2.gbd7e502-1) unstable; urgency=medium
 ibutils (1.5.7-5) unstable; urgency=medium
 
   * Fix Depends lines:
-    - libibdm-dev: add depends on libibdm1 (= ${binary:Version}) (Closes: #715085)
-    - ibutils: remove extra depends on libibdm1, debhelper should take care of that.
+    - libibdm-dev: add depends on libibdm1 (= ${binary:Version})
+      (Closes: #715085)
+    - ibutils: remove extra depends on libibdm1, debhelper should take care of
+      that.
 
  -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Sun, 12 Mar 2017 21:13:32 +0100
 
@@ -120,4 +132,3 @@ ibutils (1.2-OFED-1.4.2-1) unstable; urgency=low
   * Removed ibnlfile.pdf because we have no source
 
  -- Benoit Mortier <benoit.mortier@opensides.be>  Mon, 11 Jan 2010 22:22:00 +0100
-
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 1d59398..1712881 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,7 @@ Section: net
 Priority: optional
 Maintainer: Debian HPC Team <debian-hpc@lists.debian.org>
 Uploaders: Mehdi Dogguy <mehdi@debian.org>
-Build-Depends: debhelper (>= 9),
-               dh-autoreconf,
+Build-Depends: debhelper-compat (= 12),
                dpkg-dev (>= 1.16.0),
                graphviz,
                libibumad-dev,
diff --git a/debian/rules b/debian/rules
index d0c104f..20fb9ad 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
 # -*- makefile -*-
 
 %:
-	dh $@ --with autoreconf
+	dh $@
 
 override_dh_autoreconf:
 	dh_autoreconf autoreconf -- -f -i -I config

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/lib/debug/.build-id/80/87ff651e0547c63b18b4f5ea10df7e2294e9a6.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/98/eee95f2e59736ae76de35e52b173ce7abb149f.debug
-rw-r--r--  root/root   /usr/lib/debug/.dwz/x86_64-linux-gnu/ibutils.debug
-rw-r--r--  root/root   /usr/lib/debug/.dwz/x86_64-linux-gnu/libibdm1.debug

Files in first set of .debs but not in second

-rw-r--r--  root/root   /usr/lib/debug/.build-id/dd/d79b0094ec659b700224cc531b0a0ccafc7504.debug
-rw-r--r--  root/root   /usr/lib/debug/.build-id/ef/ed299e65551f3521576071fd76c07b5403289a.debug

Control files of package ibutils: lines which differ (wdiff format)

  • Depends: libc6 (>= 2.14), libgcc-s1 (>= 3.0), libibdm1, libopensm9 libibdm1 (>= 3.3.22), libosmcomp5 1.5.7+0.2.gbd7e502), libopensm8 (>= 3.3.22), libosmvendor5 3.3.21), libosmcomp4 (>= 3.3.22), 3.3.21), libosmvendor4 (>= 3.3.19), libstdc++6 (>= 9), libtcl8.6 (>= 8.6.0)

Control files of package ibutils-dbgsym: lines which differ (wdiff format)

  • Build-Ids: 13ae8b81ba26597d9bc0bb093c14e2d7c9b2de2f 732b4af5aa7b38412ae269de033bc45c3675bbb4 7643bf28dd5ea4a3c3ddb3381a555703a85b2af8 98eee95f2e59736ae76de35e52b173ce7abb149f af296e5d905a31bcf06e698f4291743b2608991d ddd79b0094ec659b700224cc531b0a0ccafc7504 eef6089980ad335b4c43d20f096b07bd4177222c

No differences were encountered between the control files of package libibdm-dev

Control files of package libibdm1: lines which differ (wdiff format)

  • Depends: libc6 (>= 2.14), libgcc-s1 (>= 3.0), libopensm9 libopensm8 (>= 3.3.22), libosmcomp5 3.3.21), libosmcomp4 (>= 3.3.22), libosmvendor5 3.3.21), libosmvendor4 (>= 3.3.22), 3.3.19), libstdc++6 (>= 9), libtcl8.6 (>= 8.6.0)

Control files of package libibdm1-dbgsym: lines which differ (wdiff format)

  • Build-Ids: 14173995cd668ab1633862e5e1c8d222c692ce29 446ba90bc54a9e322236ff9044c29853983f56bb 5a827388eff1b30597c068dbe7f6a7e201a9b279 efed299e65551f3521576071fd76c07b5403289a 8087ff651e0547c63b18b4f5ea10df7e2294e9a6

Full worker log Full build log