Run of cme for installation-report

Try this locally (using the lintian-brush package):

debcheckout installation-report
cd installation-report
cme-fix
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
[2021-05-20 10:33:33] Running ['cme-fix']
[2021-05-20 10:33:33] Opening branch at https://salsa.debian.org/installer-team/installation-report.git/,branch=master
[2021-05-20 10:33:34] Using cached branch https://janitor.debian.net/git/installation-report/,branch=debian%2Flatest
[2021-05-20 10:33:36] Total 9037 (delta 14), reused 0 (delta 0), pack-reused 9006
[2021-05-20 10:33:36] 
[2021-05-20 10:33:39] Total 69 (delta 0), reused 69 (delta 0), pack-reused 0
[2021-05-20 10:33:39] Workspace ready - starting.

Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done


Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree... Done


Reading state information... 0% 

Reading state information... 0%

Reading state information... Done

Warning in 'control source Standards-Version': Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '3.9.4' to '4.5.1'.

Offending value: '3.9.4'
Warning in 'control source Section': Bad section. (this cannot be fixed with 'cme fix' command)
Offending value: 'debian-installer'
Warning in 'control source Build-Depends:0': compat parameter is deprecated. Please use debhelper-compat dependency. See debhelper(7) for details.
Offending value: 'debhelper'
Warning in 'control source Build-Depends:0': debhelper dependency version is undefined. It should be 13
Offending value: 'debhelper'
Warning in 'control source Build-Depends:0': debhelper dependency is deprecated. It should be a dependency for debhelper-compat package
Offending value: 'debhelper'
Warning in 'control source Build-Depends-Indep:1': unnecessary greater-than versioned dependency: dpkg-dev (>= 1.9). Debian has oldoldstable -> 1.17.27; oldstable -> 1.18.25; stable -> 1.19.7; unstable -> 1.20.9; testing -> 1.20.9;
Offending value: 'dpkg-dev (>= 1.9)'
Configuration item 'control binary:"save-logs" Description' has a wrong value:
	Undefined mandatory value.
Connecting to api.ftp-master.debian.org to check 2 package versions. Please wait...
Got info from api.ftp-master.debian.org for 2 packages.

Full worker log