Run of fresh-snapshots for ipykernel

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Using upstream branch https://github.com/ipython/ipykernel.git (from configuration)
Total 11871 (delta 8), reused 8 (delta 3), pack-reused 11848
Using version string 6.15.2+git20220901.1.e135d6f.
No upstream upstream-revision format specified, trying tag:6.15.2
No upstream upstream-revision format specified, trying tag:ipykernel-6.15.2
No upstream upstream-revision format specified, trying tag:v6.15.2
Not including upstream history, since previous upstream version (6.15.2) is not present in packaging branch history.
Adding DFSG suffix since upstream files are excluded: 6.15.2+git20220901.1.e135d6f+ds
Looking for upstream 6.15.2+git20220901.1.e135d6f+ds in upstream branch https://github.com/ipython/ipykernel.git/.
No upstream upstream-revision format specified, trying git:e135d6f
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python310.zip:/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/local/lib/python3.10/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitorcfu7u9hn/ipykernel/debian
Opened schroot session unstable-amd64-sbuild-d3f85130-7b20-423f-8b0b-74857e4bef34 (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n               dh-python,\n               pybuild-plugin-pyproject,\n               python3-all,\n               python3-debugpy,\n               python3-flaky <!nocheck>,\n               python3-hatchling <!nocheck>,\n               python3-ipyparallel <!nocheck>,\n               python3-ipython (>= 5.8.0-2~),\n               python3-jupyter-client (>= 6.1.11~),\n               python3-matplotlib-inline,\n               python3-mock,\n               python3-nest-asyncio,\n               python3-pickleshare,\n               python3-psutil,\n               python3-pytest <!nocheck>,\n               python3-pytest-asyncio (>= 0.18.0) <!nocheck>,\n               python3-pytest-timeout <!nocheck>,\n               python3-setuptools,\n               python3-tornado,\n               python3-traitlets,\n               python3-trio']
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, bioconductor, octave-forge]
Running ['python3', '-m', 'pep517.build', '--source', '.']
Identified error: MissingPythonModule('pip', python_version=3, minimum_version=None)
Attempting to use fixer upstream requirement fixer([apt, cpan, ctan, pypi, npm, go, hackage, cran, bioconductor, octave-forge]) to address MissingPythonModule('pip', python_version=3, minimum_version=None)
Loading apt contents information
Killed
Command 'SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python310.zip:/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/local/lib/python3.10/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitorcfu7u9hn/ipykernel/debian' returned non-zero exit status 137.

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☑ command has not changed
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far. not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 1195, max open: 200)
  • ☒ change set 064d96f4-1bb3-4871-a042-515744ada3d0 is working

Full worker log