Run of multiarch-fixes for java3d

Try this locally (using the package):

debcheckout java3d
cd java3d
DEB_UPDATE_CHANGELOG=auto apply-multiarch-hints

Diff

diff --git a/debian/changelog b/debian/changelog
index 2430b73..963eb02 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+java3d (1.5.2+dfsg-18) UNRELEASED; urgency=medium
+
+  * Apply multi-arch hints.
+    + libjava3d-java-doc: Add Multi-Arch: foreign.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Fri, 16 Jul 2021 14:13:21 -0000
+
 java3d (1.5.2+dfsg-17) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/control b/debian/control
index b0804c8..b139aa9 100644
--- a/debian/control
+++ b/debian/control
@@ -54,6 +54,7 @@ Architecture: all
 Section: doc
 Depends: ${misc:Depends}
 Suggests: libjava3d-java
+Multi-Arch: foreign
 Description: Documentation for the Java3D API
  The Java 3D API enables the creation of three-dimensional graphics
  applications and Internet-based 3D applets. It provides high-level

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package libjava3d-java

Control files of package libjava3d-java-doc: lines which differ (wdiff format)

  • Multi-Arch: foreign

No differences were encountered between the control files of package libjava3d-jni

Publish History

  • 2021-09-13T10:50: Failed to create merge proposal: missing-build-diff-control (Missing build diff due to control run, but successful control run exists. Rescheduling.)

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t multiarch-fixes libjava3d-java-doc
apt install -t multiarch-fixes libjava3d-java
apt install -t multiarch-fixes libjava3d-jni

Lintian Result

Full worker log Full build log