Run of lintian-fixes for java3d

Try this locally (using the lintian-brush package):

debcheckout java3d
cd java3d
DEB_UPDATE_CHANGELOG=auto lintian-brush --exclude=upstream-metadata-file

Merge these changes:

git pull https://janitor.debian.net/git/java3d lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 2430b73..9c83abc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+java3d (1.5.2+dfsg-18) UNRELEASED; urgency=medium
+
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 16 Jun 2021 08:25:34 -0000
+
 java3d (1.5.2+dfsg-17) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de394..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index b0804c8..a3048c7 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Uploaders:
  Torsten Werner <twerner@debian.org>
 Build-Depends:
  ant-optional,
- debhelper (>= 11),
+ debhelper-compat (= 12),
  default-jdk,
  javahelper,
  libgl1-mesa-dev,

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package libjava3d-java

No differences were encountered between the control files of package libjava3d-java-doc

No differences were encountered between the control files of package libjava3d-jni

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t lintian-fixes libjava3d-java-doc
apt install -t lintian-fixes libjava3d-java
apt install -t lintian-fixes libjava3d-jni

Lintian Result

Full worker log Full build log