Run of lintian-fixes for kanyremote

Try this locally (using the lintian-brush package):

debcheckout kanyremote
cd kanyremote
lintian-brush
95
96
97
98
99
100
101
102
103
104
dpkg-source: error: cannot represent change to po/pt_BR.gmo: binary file contents changed
dpkg-source: error: add po/pt_BR.gmo in debian/source/include-binaries if you want to store the modified binary in the debian tarball
dpkg-source: error: cannot represent change to po/ru_RU.gmo: binary file contents changed
dpkg-source: error: add po/ru_RU.gmo in debian/source/include-binaries if you want to store the modified binary in the debian tarball
dpkg-source: error: cannot represent change to po/sk_SK.gmo: binary file contents changed
dpkg-source: error: add po/sk_SK.gmo in debian/source/include-binaries if you want to store the modified binary in the debian tarball
dpkg-source: error: cannot represent change to po/sv_SE.gmo: binary file contents changed
dpkg-source: error: add po/sv_SE.gmo in debian/source/include-binaries if you want to store the modified binary in the debian tarball
E: Failed to package source directory /home/janitor/tmp/tmpserk1pea/build-area/kanyremote-8.0
brz: ERROR: The build failed.

Summary

  • Set debhelper-compat version in Build-Depends. (uses-debhelper-compat-file)
  • Update renamed lintian tag names in lintian overrides. (renamed-tag)
  • Remove obsolete field Name from debian/upstream/metadata (already present in machine-readable debian/copyright).
  • Update standards version to 4.5.0, no changes needed. (out-of-date-standards-version)

Full worker log Full build log