Run of scrub-obsolete for kcoreaddons

Try this locally (using the lintian-brush package):

debcheckout kcoreaddons
cd kcoreaddons
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/kcoreaddons scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index d6d9f0b..9d3bb09 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+kcoreaddons (5.74.0-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake, pkg-kde-tools,
+      shared-mime-info.
+    + libkf5coreaddons5: Drop versioned constraint on shared-mime-info in
+      Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sun, 08 Nov 2020 06:05:12 -0000
+
 kcoreaddons (5.74.0-2) unstable; urgency=medium
 
   * Team upload to unstable.
diff --git a/debian/control b/debian/control
index c38b283..80774a6 100644
--- a/debian/control
+++ b/debian/control
@@ -3,18 +3,18 @@ Section: libs
 Priority: optional
 Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Maximiliano Curia <maxy@debian.org>
-Build-Depends: cmake (>= 3.5~),
+Build-Depends: cmake,
                debhelper-compat (= 13),
                doxygen (>= 1.8.13~),
                extra-cmake-modules (>= 5.74.0~),
                graphviz,
                libfam-dev,
                libqt5sql5-sqlite:native,
-               pkg-kde-tools (>= 0.15.16~),
+               pkg-kde-tools,
                qtbase5-dev (>= 5.12.0~),
                qttools5-dev (>= 5.4),
                qttools5-dev-tools (>= 5.4),
-               shared-mime-info (>= 1.3),
+               shared-mime-info,
 Standards-Version: 4.5.0
 Homepage: https://invent.kde.org/frameworks/kcoreaddons
 Vcs-Browser: https://salsa.debian.org/qt-kde-team/kde/kcoreaddons
@@ -103,7 +103,7 @@ Package: libkf5coreaddons5
 Architecture: any
 Multi-Arch: same
 Depends: libkf5coreaddons-data (= ${source:Version}),
-         shared-mime-info (>= 1.3),
+         shared-mime-info,
          ${misc:Depends},
          ${shlibs:Depends},
 Description: KDE Frameworks 5 addons to QtCore

Full worker log