Run of lintian-fixes for ktp-kded-integration-module

Try this locally (using the package):

debcheckout ktp-kded-integration-module
cd ktp-kded-integration-module
DEB_UPDATE_CHANGELOG=auto lintian-brush

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index ba2014e..1649f2c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,12 @@
 ktp-kded-integration-module (20.08.0-2) UNRELEASED; urgency=medium
 
+  [ Aurélien COUDERC ]
   * Fix typo in Vcs-Browse.
 
+  [ Debian Janitor ]
+  * Use secure copyright file specification URI.
+  * Update standards version to 4.5.1, no changes needed.
+
  -- Aurélien COUDERC <coucouf@debian.org>  Mon, 09 Nov 2020 18:34:16 +0100
 
 ktp-kded-integration-module (20.08.0-1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index bdcedb8..4724665 100644
--- a/debian/control
+++ b/debian/control
@@ -24,7 +24,7 @@ Build-Depends: cmake (>= 2.8.12~),
                libtelepathy-qt5-dev (>= 0.9.7~),
                pkg-kde-tools (>= 0.9),
                qtbase5-dev (>= 5.4),
-Standards-Version: 4.5.0
+Standards-Version: 4.5.1
 Rules-Requires-Root: no
 Homepage: https://projects.kde.org/projects/kde/kdenetwork/ktp-kded-module
 Vcs-Git: https://salsa.debian.org/qt-kde-team/kde/ktp-kded-module.git
diff --git a/debian/copyright b/debian/copyright
index bd8d91e..88c7450 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
 Upstream-Name: ktp-kded-integration-module
 Upstream-Contact: KDE Telepathy Project <kde-telepathy@kde.org>
 Source: http://download.kde.org/unstable/kde-telepathy/

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package kde-telepathy-integration-module

No differences were encountered between the control files of package kde-telepathy-integration-module-dbgsym

Publish History

  • 2021-08-21T13:03: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-08-21T12:59: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t lintian-fixes kde-telepathy-integration-module-dbgsym
apt install -t lintian-fixes kde-telepathy-integration-module

Lintian Result

Full worker log Full build log