Run of lintian-fixes for libconvert-pem-perl

Try this locally (using the lintian-brush package):

debcheckout libconvert-pem-perl
cd libconvert-pem-perl
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/libconvert-pem-perl lintian-fixes/main

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2018-12-10 16:55:32 +0000
+++ b/debian/changelog	2019-08-10 03:11:51 +0000
@@ -14,6 +14,11 @@
   [ Laurent Baillet ]
   * fix lintian file-contains-trailing-whitespace warning
 
+  [ Debian Janitor ]
+  * Bump debhelper from deprecated 7 to 12.
+  * Set upstream metadata fields: Contact, Name, Repository.
+  * Add missing dependency on libmodule-install-perl.
+
  -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 30 Jan 2016 20:03:35 +0100
 
 libconvert-pem-perl (0.08-2) unstable; urgency=low

=== removed file 'debian/compat'
--- a/debian/compat	2010-12-25 19:19:22 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-7

=== modified file 'debian/control'
--- a/debian/control	2018-02-25 14:09:11 +0000
+++ b/debian/control	2019-08-10 03:11:51 +0000
@@ -4,7 +4,7 @@
 Section: perl
 Testsuite: autopkgtest-pkg-perl
 Priority: optional
-Build-Depends: debhelper (>= 7)
+Build-Depends: debhelper-compat (= 12), libmodule-install-perl
 Build-Depends-Indep: libclass-errorhandler-perl,
                      libconvert-asn1-perl,
                      libcrypt-des-ede3-perl,

=== added directory 'debian/upstream'
=== added file 'debian/upstream/metadata'
--- a/debian/upstream/metadata	1970-01-01 00:00:00 +0000
+++ b/debian/upstream/metadata	2019-08-10 03:10:13 +0000
@@ -0,0 +1,4 @@
+Name: Convert-PEM
+Contact: Benjamin Trott <cpan@stupidfool.org>
+Repository: git://github.com/btrott/Convert-PEM.git
+Repository-Browse: https://github.com/btrott/Convert-PEM

Full build log Full worker log