Run of scrub-obsolete for libcrypt-unixcrypt-perl

Try this locally (using the lintian-brush package):

debcheckout libcrypt-unixcrypt-perl
cd libcrypt-unixcrypt-perl
deb-scrub-obsolete --update-changelog

Merge these changes:

Diff

diff --git a/debian/changelog b/debian/changelog
index b9b30f0..8290ca2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,10 @@ libcrypt-unixcrypt-perl (1.0-8) UNRELEASED; urgency=medium
   [ gregor herrmann ]
   * debian/watch: use uscan version 4.
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends-Indep: Drop versioned constraint on perl.
+
  -- Damyan Ivanov <dmn@debian.org>  Sun, 03 Dec 2017 22:43:28 +0000
 
 libcrypt-unixcrypt-perl (1.0-7.1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index d74ca63..cf90967 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
 Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
 Uploaders: Axel Beckert <abe@debian.org>
 Build-Depends: debhelper-compat (= 12)
-Build-Depends-Indep: perl (>= 5.8.0-7)
+Build-Depends-Indep: perl
 Standards-Version: 4.1.3
 Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libcrypt-unixcrypt-perl.git
 Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libcrypt-unixcrypt-perl

Debdiff

File lists identical (after any substitutions)

No differences were encountered in the control files

Publish History

  • 2021-02-28T04:28: Successfully pushed (Success)

Full worker log Full build log