Run of multiarch-fixes for libcypher-parser

Try this locally (using the lintian-brush package):

debcheckout libcypher-parser
cd libcypher-parser
apply-multiarch-hints

Merge these changes:

git pull https://janitor.debian.net/git/libcypher-parser multiarch-fixes/main

Summary

Multi-arch fixes.

Diff

diff --git a/debian/changelog b/debian/changelog
index e9e53e3..918fb44 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ libcypher-parser (0.6.2-2) UNRELEASED; urgency=medium
   * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
     Repository-Browse.
   * Drop unnecessary dependency on dh-autoreconf.
+  * Apply multi-arch hints.
+    + libcypher-parser-doc: Add Multi-Arch: foreign.
 
  -- Debian Janitor <janitor@jelmer.uk>  Tue, 28 Apr 2020 19:21:25 +0000
 
diff --git a/debian/control b/debian/control
index 10d585a..9707c30 100644
--- a/debian/control
+++ b/debian/control
@@ -58,6 +58,7 @@ Section: doc
 Architecture: all
 Depends: libjs-jquery, ${misc:Depends}
 Recommends: libcypher-parser-dev
+Multi-Arch: foreign
 Description: Documentation for libcypher-parser
  Cypher is a graph query language that allows for expressive and efficient
  querying of graph data.

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package cypher-lint

No differences were encountered between the control files of package cypher-lint-dbgsym

No differences were encountered between the control files of package libcypher-parser-dev

Control files of package libcypher-parser-doc: lines which differ (wdiff format)

  • Multi-Arch: foreign

No differences were encountered between the control files of package libcypher-parser8

No differences were encountered between the control files of package libcypher-parser8-dbgsym

Publish History

Full worker log Full build log