Run of fresh-snapshots for libdevel-nytprof-perl

Merge these changes:

git pull https://janitor.debian.net/git/libdevel-nytprof-perl fresh-snapshots/main
git pull https://janitor.debian.net/git/libdevel-nytprof-perl fresh-snapshots/pristine-tar
git pull https://janitor.debian.net/git/libdevel-nytprof-perl fresh-snapshots/upstream

Summary

Merged new upstream version: 6.11+git20211111.1.2b3b037+dfsg (was: 6.11+dfsg).

Diff

Branch: main

Diff is too long (more than 200 lines). Download the raw diff.

Branch: pristine-tar

diff --git a/libdevel-nytprof-perl_6.11+git20211111.1.2b3b037+dfsg.orig.tar.gz.delta b/libdevel-nytprof-perl_6.11+git20211111.1.2b3b037+dfsg.orig.tar.gz.delta
new file mode 100644
index 0000000..f4ec65f
Binary files /dev/null and b/libdevel-nytprof-perl_6.11+git20211111.1.2b3b037+dfsg.orig.tar.gz.delta differ
diff --git a/libdevel-nytprof-perl_6.11+git20211111.1.2b3b037+dfsg.orig.tar.gz.id b/libdevel-nytprof-perl_6.11+git20211111.1.2b3b037+dfsg.orig.tar.gz.id
new file mode 100644
index 0000000..244cf4d
--- /dev/null
+++ b/libdevel-nytprof-perl_6.11+git20211111.1.2b3b037+dfsg.orig.tar.gz.id
@@ -0,0 +1 @@
+22dfce8304e2c34fb6328f5487ec1bce6682c9a7

Branch: upstream

Tag: upstream/6.11+git20211111.1.2b3b037+dfsg
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..6e898ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,41 @@
+# /
+FileHandle.c
+FileHandle.o
+MANIFEST.bak
+MYMETA.json
+MYMETA.yml
+Makefile
+Makefile.old
+NYTProf.bs
+NYTProf.c
+NYTProf.o
+blib/
+*.tar.gz
+*.o
+*.obj
+*.pdb
+*.def
+*.c
+*.bs
+*.out
+.*.swp
+nytprof-50-errno.out
+/t/*.new
+/t/*.newp
+/t/*.out
+/t/*.calls_new
+/t/*.rdt_new
+/t/*.rdt_newp
+/t/nytprof_t.out
+/t/nytprof-test51-*.out
+/t/nytprof_test30-fork-*.out.*
+/t/*_outdir
+/t/auto
+pm_to_blib
+/_eumm/
+dll.base
+dll.exp
+NYTProf_def.old
+/cover_db/
+MYMETA.json.lock
+Devel-NYTProf-*/
diff --git a/META.json b/META.json
index fd8b1fd..9ef6c75 100644
--- a/META.json
+++ b/META.json
@@ -45,6 +45,7 @@
       "test" : {
          "requires" : {
             "Capture::Tiny" : "0",
+            "Sub::Name" : "0.11",
             "Test::Differences" : "0.60",
             "Test::More" : "0.84"
          }
diff --git a/META.yml b/META.yml
index be2e0e5..db0ac4c 100644
--- a/META.yml
+++ b/META.yml
@@ -5,6 +5,7 @@ author:
 build_requires:
   Capture::Tiny: '0'
   ExtUtils::MakeMaker: '0'
+  Sub::Name: '0.11'
   Test::Differences: '0.60'
   Test::More: '0.84'
 configure_requires:
diff --git a/Makefile.PL b/Makefile.PL
index 590bf7a..810564a 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -114,10 +114,10 @@ $mm_opts{CCFLAGS}  = "-pg"  if $opt_pg;
 
 if( $ExtUtils::MakeMaker::VERSION >= 6.46 ) {
     $mm_opts{META_MERGE} = {
-    	"meta-spec" => { version => 2 },
-	no_index => {
-	    package => [ 'SVG' ], # in bin/flamegraph.pl
-	},
+        "meta-spec" => { version => 2 },
+        no_index => {
+            package => [ 'SVG' ], # in bin/flamegraph.pl
+        },
         resources => {
             license     => 'http://dev.perl.org/licenses/',
             homepage    => 'https://code.google.com/p/perl-devel-nytprof/',
@@ -146,6 +146,7 @@ $mm_opts{TEST_REQUIRES} = {
     'Test::More'   => '0.84',
     'Test::Differences' => '0.60',
     'Capture::Tiny' => 0,
+    'Sub::Name' => '0.11',
 };
 
 $mm_opts{BUILD_REQUIRES} = {
@@ -261,20 +262,6 @@ slowops::
 	    > slowops.h
 	$(PERL) -e "warn qq{NOTE: slowops.h will need manual editing to restore lost #ifdef's around some opcodes!\n}";
 
-svnmanifest::
-	svn list -R .@HEAD | sort | grep -v '/$$' > MANIFEST
-	svn diff MANIFEST
-
-checkkeywords:
-	$(RM_RF) blib
-	find .  \( -name .svn -prune -or -name t -prune -or -name \*.pm -or -name \*.PL -or -name \*.pl \) -type f \
-	    -exec bash -c '[ "$$(svn pg svn:keywords {})" != "Id Revision Date" ] && echo svn propset svn:keywords \"Id Revision Date\" {}' \;
-
-checkpod:
-	$(RM_RF) blib
-	find . -type f \( -name .svn -prune -o -name \*.pm -o -name \*.PL -o -name \*.pl \) \
-	    -exec podchecker {} \; 2>&1 | grep -v "pod syntax OK"
-
 PERLTIDY=perltidy --profile=.perltidyrc -nst -b
 perltidy:
 	$(PERLTIDY) bin/nytprofhtml bin/nytprofcsv

Publish Blockers

  • ☑ run was successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=update deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 1257, max open: 300)
  • ☑ change set 9866aaa9-bb12-440a-bc34-46fbe714f514 is ready

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t fresh-snapshots libdevel-nytprof-perl-dbgsymapt install -t fresh-snapshots libdevel-nytprof-perl

Full worker log Full build log