Run of cme for libedit

Try this locally (using the cme package):

debcheckout libedit
cd libedit
cme-fix
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
[2021-05-22 11:07:12] Running ['cme-fix']
[2021-05-22 11:07:12] Opening branch at https://salsa.debian.org/debian/libedit.git/,branch=master
[2021-05-22 11:07:13] Using cached branch https://janitor.debian.net/git/libedit/,branch=debian%2Flatest
[2021-05-22 11:07:15] Total 1248 (delta 0), reused 0 (delta 0), pack-reused 1248
[2021-05-22 11:07:18] 7/33)
[2021-05-22 11:07:18] Total 129 (delta 33), reused 33 (delta 33), pack-reused 96
[2021-05-22 11:07:25] All changes applied successfully.
[2021-05-22 11:07:25] Workspace ready - starting.

Reading package lists... 0%

Reading package lists... 0%

Reading package lists... 0%

Reading package lists... 95%

Reading package lists... 95%

Reading package lists... 95%

Reading package lists... 95%

Reading package lists... 96%

Reading package lists... 96%

Reading package lists... 96%

Reading package lists... 96%

Reading package lists... Done


Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree... 83%

Building dependency tree... Done


Reading state information... 0% 

Reading state information... 0%

Reading state information... Done

Warning in 'control source Standards-Version': Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.2.1' to '4.5.1'.

Offending value: '4.2.1'
Warning in 'control source Build-Depends:3': unnecessary greater-than versioned dependency: libbsd-dev (>= 0.1.3). Debian has oldoldstable -> 0.7.0-2; oldstable -> 0.8.3-1; stable -> 0.9.1-2+deb10u1; unstable -> 0.11.3-1; testing -> 0.11.3-1;
Offending value: 'libbsd-dev (>= 0.1.3)'
Warning in 'control binary:"libedit-dev" Depends:2': unnecessary greater-than versioned dependency: libbsd-dev (>= 0.1.3). Debian has oldoldstable -> 0.7.0-2; oldstable -> 0.8.3-1; stable -> 0.9.1-2+deb10u1; unstable -> 0.11.3-1; testing -> 0.11.3-1;
Offending value: 'libbsd-dev (>= 0.1.3)'
Warning in 'control binary:"libeditreadline-dev" Conflicts:1': package libreadline5-dev is unknown. Check for typos if not a virtual package.
Offending value: 'libreadline5-dev'
Connecting to api.ftp-master.debian.org to check 7 package versions. Please wait...
Got info from api.ftp-master.debian.org for 6 packages.
Connecting to api.ftp-master.debian.org to check libreadline5-dev versions. Please wait...
got no info for libreadline5-dev

Changes applied to dpkg configuration:
- control source Standards-Version: '4.2.1' -> '4.5.1' # applied fix for :Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.2.1' to '4.5.1'.

- control source Build-Depends:3: 'libbsd-dev (>= 0.1.3)' -> 'libbsd-dev' # applied fix for :unnecessary greater-than versioned dependency: libbsd-dev (>= 0.1.3). Debian has oldoldstable -> 0.7.0-2; oldstable -> 0.8.3-1; stable -> 0.9.1-2+deb10u1; unstable -> 0.11.3-1; testing -> 0.11.3-1;
- control binary:"libedit-dev" Depends:2: 'libbsd-dev (>= 0.1.3)' -> 'libbsd-dev' # applied fix for :unnecessary greater-than versioned dependency: libbsd-dev (>= 0.1.3). Debian has oldoldstable -> 0.7.0-2; oldstable -> 0.8.3-1; stable -> 0.9.1-2+deb10u1; unstable -> 0.11.3-1; testing -> 0.11.3-1;
- patches:"update-soname.diff" Synopsis has new value: 'Update soname.diff' # applied fix for :Empty synopsis
- patches:"libbsd.patch" Synopsis has new value: 'Libbsd' # applied fix for :Empty synopsis
- patches:"wcsdup.patch" Synopsis has new value: 'Wcsdup' # applied fix for :Empty synopsis
- patches:"PATH_MAX.diff" Synopsis has new value: 'PATH_MAX.diff' # applied fix for :Empty synopsis
- patches:"conflictmanpages.diff" Synopsis has new value: 'Conflictmanpages.diff' # applied fix for :Empty synopsis
- patches:"termcap.patch" Synopsis has new value: 'Termcap' # applied fix for :Empty synopsis

[2021-05-22 11:07:44] Committing to: /tmp/janitorw31183i4/libedit/
[2021-05-22 11:07:44] modified debian/control
[2021-05-22 11:07:44] modified debian/patches/PATH_MAX.diff
[2021-05-22 11:07:44] modified debian/patches/conflictmanpages.diff
[2021-05-22 11:07:44] modified debian/patches/libbsd.patch
[2021-05-22 11:07:44] modified debian/patches/termcap.patch
[2021-05-22 11:07:44] modified debian/patches/update-soname.diff
[2021-05-22 11:07:44] modified debian/patches/wcsdup.patch
[2021-05-22 11:07:48] Committed revision 124.
[2021-05-22 11:07:53] Opened schroot session unstable-amd64-sbuild-e3f32f3f-3f1e-4f3b-938c-bdc07fa8c833 (from unstable-amd64-sbuild)
[2021-05-22 11:07:53] Using fixers: [PgBuildExtOutOfDateControlFixer(), SimpleBuildFixer(MissingConfigure, fix_missing_configure), SimpleBuildFixer(MissingAutomakeInput, fix_missing_automake_input), SimpleBuildFixer(MissingConfigStatusInput, fix_missing_config_status_input), SimpleBuildFixer(MissingPerlFile, fix_missing_makefile_pl), SimpleBuildFixer(DebcargoUnacceptablePredicate, coerce_unacceptable_predicate), DependencyBuildFixer(AptFetchFailure, retry_apt_failure), PackageDependencyFixer(AptResolver(<ognibuild.debian.apt.AptManager object at 0x7faba268bca0>, [functools.partial(<function python_tie_breaker at 0x7faba39ab4c0>, <GitWorkingTree of /tmp/janitorw31183i4/libedit>, ''), BuildDependencyTieBreaker('/var/run/schroot/mount/unstable-amd64-sbuild-e3f32f3f-3f1e-4f3b-938c-bdc07fa8c833'), <function popcon_tie_breaker at 0x7faba26cbf70>]))]
[2021-05-22 11:07:53] Building debian packages, running 'sbuild -A -s -v'.
[2021-05-22 11:10:09] Built ['libedit_3.1-20210419-1~exp1~cme+unc1_amd64.changes'].
[2021-05-22 11:10:10] Running lintian
[2021-05-22 11:10:19] Pushing result branch to RemoteVcsManager('https://janitor.debian.net/')
[2021-05-22 11:10:20] warning: ignoring broken ref refs/heads/unchanged/main
[2021-05-22 11:10:20] git: cannot lock ref 'refs/tags/2b08530c-c4f4-4ef1-9946-1af0e3bb0074/main': reference already exists
[2021-05-22 11:10:20] git: cannot lock ref 'refs/heads/cme/main': reference already exists
[2021-05-22 11:10:20] Pushing packaging branch cache to https://janitor.debian.net/git/libedit,branch=debian%2Flatest
[2021-05-22 11:10:27] warning: ignoring broken ref refs/heads/unchanged/main
[2021-05-22 11:10:27] git: cannot lock ref 'refs/heads/debian/latest': is at b4f89a24c3702464aa25f829a97a1198955f0ed2 but expected 8cb61496e83f89a179d9a59e369d5865534bed51
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20190324': is at 42b56220befcb7959ecc3eaa1f0f4f8c2be9269e but expected 6f05551bd601ab9a7ae5331610e2644a2478a069
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20140213': is at 77b1adbdca0847ddadc4d1b2429c385745baabb3 but expected 26ca65eb069a4857279bd1ed247c774ce2dea3c3
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20160618': is at 4e664ba75217f389201a1df758ae4037608edbb0 but expected 127e9f837f0721de8d7f49b56b398856955cce1f
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20210216': reference already exists
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20191025-1': reference already exists
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20191211': reference already exists
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20181209': is at 41c3066d612ae3f695bb248069f1694ac8b00b68 but expected 38d5a11eff824186021bdbb9fb49297e1bb48341
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20140620': is at 43e2f1be6d2a407483603afd4e79df296654ba45 but expected 17a905aef293c710ae9ba90f41f8f5a37cf86c3c
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20210419': reference already exists
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20191231': reference already exists
[2021-05-22 11:10:27] git: cannot lock ref 'refs/tags/upstream/3.1-20180525': is at 717abe3c016a64dbcb522db4eb5fa3dd2caac60b but expected 7a8d02b20ac6b07b9f6175b0900eb77f3986da0c
Traceback (most recent call last):
  File "/srv/janitor/debian-janitor/janitor/pull_worker.py", line 272, in run_worker
    push_branch(
  File "/srv/janitor/debian-janitor/janitor/pull_worker.py", line 187, in push_branch
    target.push_branch(
  File "/srv/janitor/debian-janitor/breezy/breezy/git/remote.py", line 685, in push_branch
    raise RemoteGitError(error)
breezy.git.remote.RemoteGitError: failed to update ref

Full worker log Full build log