Run of lintian-fixes for libemail-address-list-perl

Try this locally (using the lintian-brush package):

debcheckout libemail-address-list-perl
cd libemail-address-list-perl
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/libemail-address-list-perl lintian-fixes/main

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2019-02-06 18:41:36 +0000
+++ b/debian/changelog	2019-12-13 08:17:54 +0000
@@ -1,3 +1,14 @@
+libemail-address-list-perl (0.06-2) UNRELEASED; urgency=medium
+
+  * Set upstream metadata fields: Contact, Name.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Remove obsolete fields Contact, Name from debian/upstream/metadata
+    (already present in machine-readable debian/copyright).
+  * Update standards version to 4.4.1, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 08 Jul 2019 03:56:01 +0000
+
 libemail-address-list-perl (0.06-1) unstable; urgency=medium
 
   * Team upload.

=== removed file 'debian/compat'
--- a/debian/compat	2019-02-06 18:21:53 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-11

=== modified file 'debian/control'
--- a/debian/control	2019-02-06 18:39:30 +0000
+++ b/debian/control	2019-12-13 08:17:54 +0000
@@ -5,11 +5,11 @@
 Section: perl
 Testsuite: autopkgtest-pkg-perl
 Priority: optional
-Build-Depends: debhelper (>= 11)
+Build-Depends: debhelper-compat (= 12)
 Build-Depends-Indep: libemail-address-perl,
                      libjson-perl,
                      perl
-Standards-Version: 4.3.0
+Standards-Version: 4.4.1
 Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libemail-address-list-perl
 Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libemail-address-list-perl.git
 Homepage: https://metacpan.org/release/Email-Address-List

Full build log Full worker log